Forum Stats

  • 3,852,328 Users
  • 2,264,092 Discussions


11g on VMWare Not Starting Service, ORA-12560 etc.

657971 Member Posts: 6
edited Sep 4, 2008 9:37PM in General Database Discussions
It's obvious that my Listener is up and running but that the Oracle Service never got started. I'm using a VMware instance of Win2003 Server with Oracle 11g on it.

I'm having very similar issues to the person that wrote this:
ORA-12560 at service startup *** ( protocol adapter error )

I'm working on a VMware instance, and I'm not trying to connect from another machine, so I don't think I'll need a 'tnsnames.ora'.
I did review my listener.ora and sqlnet.ora
and I did adjust my hosts file (on this Win2003 Server, vmware instance), adding an entry to resolve local host and also the FQ machine name to
This I was unsure about since when I ping the FQ machine name (property of My Computer) I get a unique ip address.

There's also the VMware issues of what Ethernet connection setting to use: Bridged, NAT or Host Only.

I've tried to look at logs and config files: connection, startup, trace log, etc.

Set tracing on and saw some errors in the trace, but not sure about how to go about debugging those.

It's apparent that I'll need to start the Database with oradim or a version specific command, oradimxx but I wasn't sure what to use for my -pfile parameter, or how to create orainit.ora or configure that file.

One last thing: Previously my program group for 11g had 'Enterprise Manager' which brought up the webpage and showed that the database was up, uptime and other stats. Now that menu link has disappeared.

Any suggestions on all of these issues ? TIA.


  • damorgan
    damorgan Member Posts: 14,464 Bronze Crown
    VMWare is unsupported for Oracle. Give serious consideration to using a supported environment. I would personally suggest Oracle Enterprise Linux.
  • 585319
    585319 Member Posts: 511
    edited Sep 4, 2008 3:57PM

    VMWare is an hypervisor, and the OP installed Windows 2003 on top of it... Windows 2003 + Oracle is a certified mix. Just as Oracle Enterprise Linux, but both are Operating Systems.

    What Oracle hasn't bothered to formally document is the relation among hypervisors and it's products.

    PS: if Oracle DBMS is not supported for VMWare virtualization solutions it will miss the 70-80% of market share for VM, isn't that a big mistake?


  • 529937
    529937 Member Posts: 958
    edited Sep 4, 2008 3:57PM
    Even though VMware is not supported, they are commonly used for QA and Dev environments to save $$$$. Being that's it's running on VMWARE is invisible to Oracle. Now, have you tried to start the LISTENER yourself?

    Your Environment should have already been exported.

    From the COmmand line:
    lsnrctl start
  • Robert Geier
    Robert Geier Member Posts: 2,989
    It would take an encyclopedia to try to answer all of your questions. Please choose a specific issue and post the error messages, startup commands, and configuration files and you are more likely to get useful help.

    Many DBAs run Oracle on VMware with no problem, so as long as you are only testing the install, you don't need to worry about whether it is supported. Not sure why anyone would choose to run Oracle on Windows though. If you have vmware you can easily install linux and learn how a proper server is configured.
  • 585319
    585319 Member Posts: 511
    Why the Oracle service cannot start? Have you tried to start it up manually?

    If some links are missing from the Oracle group... are you the only one with access to this VM? seems that
    a) Oracle didn't installed right after all
    b) Somebody mistakenly tried to deinstall oracle or just removed the Enterprise Manager link (which you may access using http://localhost:1158/em or whatever the port was choosen for config)


  • damorgan
    damorgan Member Posts: 14,464 Bronze Crown
    Oracle does NOT support the database on VMWare and has no reason to do so for a variety of reasons.

    Oracle supports its own VM for stand-alone and the best VM on the planet, zVM, for both stand-alone and RAC.
  • 585319
    585319 Member Posts: 511
    edited Sep 4, 2008 9:37PM
    Yeah , of course Oracle offers his own hypervisor... that's one very powerful reason.

    Please provide us with proper references to support your statements, we all will appreciate that.



    Edited by: Ignacio Ruiz on Sep 4, 2008 8:20 PM

    I've found the answer on Metalink Note 249212.1, which basically says that Oracle doesn't certifies any product on any VMWare virtualization products, however Oracle will support the product isolating the relationship among operating system and the Oracle product, to known issues or not known issues BUT not related to the existence of an hypervisor layer (VMWare in this case, and distinct of Oracle VM).

    In other words, if you have an issue where a certified OS+Oracle product is running over a VMWare product, you'll be lucky if the error is replicated without the VMWare product, otherwise it will be an issue induced from the hypervisor layer, therefore the hypervisor provider must solve.

    Anybody interested will follow similar proceedings with another VM products like Virtuozzo (Note 412431.1), Xen (Note 417770.1), this clearly shows a commercial strategy...not technical barriers.
  • HJR
    HJR Member Posts: 295
    First, Oracle does support its products running on VMware, to the extent that a problem can be replicated outside a virtual environment. What they won't support is anything that goes wrong which cannot be replicated in a physical environment.

    Second, you'll find life a lot easier in VMware if you stick to Bridged networking, because that makes the virtual machine behave, from the networking perspective, as though it were a full-bore, perfectly-normal, physical machine. All other options do strange things to the networking stack and I would not recommend them.

    Obviously, within the virtual machine, you will need to assign a fixed IP address. Easiest thing to do there, I think, is to see what the VMware virtual DHCP server assigns to your virtual machine by way of IP address, and then use Windows Networking to make that same address the permanent, static IP address. You could instead manually configure the VMware DHCP server to do lease reservations, but I wouldn't bother because it's a lot more complicated and the outcome is the same.

    I have no idea how program groups can appear and disappear from the start menu, except if you are logging on as a different user each time. Make sure you log on as local administrator to install Oracle and always do so thereafter. Either that, or make your normal log on a member of the local administrators group, and then log on as yourself consistently to install and operate Oracle.
This discussion has been closed.