Forum Stats

  • 3,741,216 Users
  • 2,248,392 Discussions
  • 7,861,678 Comments

Discussions

cx_Oracle & Oracle's Instant Client

x0d3r
x0d3r Member Posts: 144
edited Feb 25, 2011 3:32PM in Python
Hello there, first time here :) , im having many issues trying to set up cx_Oracle module on my Ubuntu OS. My question is if the Oracle's Instant Client version it must be the same as my Oracle's Server Version ??

Answers

  • sun1991
    sun1991 Member Posts: 11
    Seems so.
    I did 5.0.4 it on windows, if OCI not match, Oracle will return error says attribute not supported or something like this.
  • Christopher Jones-Oracle
    Christopher Jones-Oracle Member Posts: 1,636 Employee
    There is no Oracle requirement for the client & database libraries to be exact. For example, Instant Client 11g will connect to 10g databases.

    If you have a database on the same machine as Instant Client then you need to be careful about which tools pick up which of the two sets of Oracle libraries. This is a common problem for Windows users.

    Also on Windows you do need to match the Oracle libraries to those that whatever tool (e.g. cx_Oracle) was built with.
This discussion has been closed.