Forum Stats

  • 3,759,024 Users
  • 2,251,493 Discussions
  • 7,870,471 Comments

Discussions

Platform performance

13567

Comments

  • BluShadow
    BluShadow Member, Moderator Posts: 41,383 Red Diamond
    edited May 11, 2021 7:28AM

    I haven't tested today as I've only just come online, but when it was happening yesterday, it seemed that I was fine when I started posting a reply, and I could type a reasonable amount of reply, but then after a few minutes it would hang, show the error message and i could click Wait, and then if I waited I may be lucky and be able to type some more, but usually just a word or two before it would pop up again. Refreshing the page would bring me back with the saved draft of my message and I may be able to type another sentance or two before it would start happening again.

    Unfortunately, the error message in the screenshot appears truncated and the window doesn't allow me to do anything to look deeper at the message. I'll see how it gets on today and if I can find out anything more.


    Edit: p.s. forgot to mention, in the screenshot "Combination that leads to an error: Illegal use.." is the name of the thread title on the forum, not an actual error message. Wouldn't want your developers looking for that as an error message 😁

  • BluShadow
    BluShadow Member, Moderator Posts: 41,383 Red Diamond

    Note, it's definitely happening again today.

    if we are still not able to reproduce I do reach back out to see if the person reporting the issue is able to provide any more context for our testing, as sometimes the initial report is very general, but once we start talking we discover it is only occurs when certain actions are taken or sometimes it's when actions are done in a specific order.


    I'm not doing anything special.

    1. See notification that someone has replied to a thread I'm involved in.
    2. Click notification to open up that thread
    3. Read the current responses
    4. Start typing in the "Leave a Comment" box to add my reply
    5. Notice the occasional pause as it saves draft versions
    6. After a couple of minutes the "Page Unresponsive" message pops up, and I click "Wait"
    7. Whilst waiting i cannot type anything further
    8. If I'm lucky it may come back enough for me to type a little more before it pops up the unresponsive message again, if I'm unlucky I can't type anything and the message just pops up again.
    9. If I click refresh on my browser it tries to reload the page - again if I'm lucky it will reload with the last saved draft and i can continue typing for a bit before it happens again, if I'm unlucky it struggles to reload the page, and I'm better off just copying the URL, closing the tab on the browser, and pasting the URL in to a new tab so I can then continue on and hope I have enough time to finish my response before it happens again.


    I'd say that opening up a thread an posting a reply is nothing unusual for a forum 🤔

  • Paulzip
    Paulzip Member Posts: 8,452 Blue Diamond
    edited May 11, 2021 12:03PM

    @BluShadow Exactly what I experience. It's worth noting the CPU usage goes through the roof during the non responsive time - pretty much maxes out a core. It makes replying in these occasions impossible.

    Perhaps Oracle employees inability to replicate it, is domain related? I suggest they connect from outside of their domain or use a VPN or such and test.

  • BluShadow
    BluShadow Member, Moderator Posts: 41,383 Red Diamond

    I'll have to check the CPU with task manager. As I'm remotely controlling my office computer from home (over a year since I've been in the office now! woohoo!) I don't get to hear it's poor CPU fans whirring away under the strain. 😂

  • fac586
    fac586 Senior Technical Architect Member Posts: 19,931 Red Diamond

    Still happening. Slow draft saves and freezes whilst typing in this response post after the two code blocks were formatted.

  • BluShadow
    BluShadow Member, Moderator Posts: 41,383 Red Diamond

    I wonder if it's related to formatting bocks as code then? Obviously that's something we commonly do on this community, and I certainly don't seem to notice anything when just typing a normal reply of text, apart from the occasional delay when it's saving a draft.

    On thing I did just notice though... The draft saving does temporarily pause my typing using Chrome on Windoze 7, but at the minute I'm using Edge on Windows 10 and that just saved a draft in the background (I saw the "Save Draft" and "Post Comment" button grey out whilst it did it), but it didn't prevent me from continuing my typing.

    Perhaps the platform only works best on something like modern browser or Edge? Hmmm....

  • fac586
    fac586 Senior Technical Architect Member Posts: 19,931 Red Diamond

    I wonder if it's related to formatting bocks as code then? Obviously that's something we commonly do on this community, and I certainly don't seem to notice anything when just typing a normal reply of text, apart from the occasional delay when it's saving a draft.

    There certainly seems to be a correlation with increased use of enhanced content, whether that be code blocks, quotes, or images.

    I even wonder whether it has something to do with the type of code posted. Those of us who are reporting this are using SQL and PL/SQL. In the first few weeks of the new platform, I noticed it was identifying and formatting SQL and PL/SQL code as various exotic languages.

    In the latest post I referred to above, the SQL fragment has been identified as Go:

    <pre class="code codeBlock hljs go" spellcheck="false" tabindex="0">
    

    Would it not be helpful for Oracle's community platform to be able to recognise the two most common languages used in the company's flagship product?

    Perhaps the platform only works best on something like modern browser or Edge?

    Edge is now a fork of Chromium, so up-to-date versions of Edge and Chrome are based on the same technologies. I am primarily using the latest Safari version on macOS, and the problem occurs in all three browsers.

  • BluShadow
    BluShadow Member, Moderator Posts: 41,383 Red Diamond

    LOL! Yeah, even the SQL and PL/SQL forum states:

    SQL is the most popular and powerful relational database language the world has ever known, and Oracle SQL is the most popular and powerful SQL variant. PL/SQL stands for Procedural Language extensions to SQL and is the best database programming language on the planet, period. But then we might be a little bit biased. :-)


    Just that it's not natively recognised/supported by the forum 🤣

  • Paulzip
    Paulzip Member Posts: 8,452 Blue Diamond
    edited May 21, 2021 12:11PM

    Nothing surprises me with this forum to be honest, and the authors of it.

    They seem incapable of finding and fixing very obvious and numerous bugs, that most of us see every time we use it.

    You can't expect them to support the main languages of the platform the forum exists for, can you? 🙄

  • BluShadow
    BluShadow Member, Moderator Posts: 41,383 Red Diamond

    This issue is still happening. Browser just hanging when I'm posting a response and it goes off to save the draft (I can tell because the first thing that does is disable the "Post Comment" button while it's doing it.

    The only way I've got around it is to close the tab on the browser, then return to the thread in the hope that the draft was saved and I've not lost my response, and then I can carry on (until the next time it does it).

    The responses I was doing it on this morning did contain quoted text and code blocks.

    I wonder if it get's delayed because it goes off to check the content for spam or something which is more time consuming, rather than just save the draft as it is and only check for spam one you click "Post Comment"?