5 Replies Latest reply: Dec 21, 2009 9:56 AM by 506787 RSS

    Mailx command not found

    kkrm333
      Hi,

      When I tried to use mailx from command prompt, it is saying command not found.
      When I checked # rpm -q mailx, it is showing
      mailx-8.1.1-44.2.2
      but, mailx is not found in /usr/sbin
      I tried yum install mailx, saying already installed.
      Loading "fastestmirror" plugin
      Loading mirror speeds from cached hostfile
      * base: CYBERUSE
      * updates: CYBERUSE
      * addons: mirror.skiplink.com
      * extras: centos.mbni.med.umich.edu
      base 100% |=========================| 2.1 kB 00:00
      updates 100% |=========================| 1.9 kB 00:00
      addons 100% |=========================| 951 B 00:00
      extras 100% |=========================| 1.1 kB 00:00
      Setting up Install Process
      Parsing package install arguments
      Package mailx - 8.1.1-44.2.2.x86_64 is already installed.
      Nothing to do
      What is the problem?

      Thanks,
      Kavitha
        • 1. Re: Mailx command not found
          506787
          use:
          rpm -ql mailx
          to find out which files are in the package
          • 2. Re: Mailx command not found
            kkrm333
            It is showing

            /bin/mail
            /etc/mail.rc
            /usr/bin/Mail
            /usr/lib/mail.help
            /usr/lib/mail.tildehelp
            /usr/share/man/man1/Mail.1.gz
            /usr/share/man/man1/mail.1.gz

            There is no mailx?
            • 3. Re: Mailx command not found
              506787
              that's correct. to find the package which contains the mailx command issue:
               yum provides */mailx 
              • 4. Re: Mailx command not found
                kkrm333
                Hi,

                When I tried

                yum provides */mailx

                OUTPUT:
                Loading "fastestmirror" plugin
                Loading mirror speeds from cached hostfile

                * base: www.cyberuse.com
                * updates: www.cyberuse.com
                * addons: mirror.skiplink.com

                * extras: centos.mbni.med.umich.edu

                base 100% |=========================| 2.1 kB 00:00
                updates 100% |=========================| 1.9 kB 00:00
                addons 100% |=========================| 951 B 00:00
                extras 100% |=========================| 1.1 kB 00:00

                filelists.sqlite.bz2 100% |=========================| 3.9 MB 00:00
                filelists.sqlite.bz2 100% |=========================| 1.5 MB 00:00
                filelists.xml.gz 100% |=========================| 176 kB 00:00
                filelists.xml.gz 100% |=========================| 196 B 00:00
                redhat-lsb.i386 : LSB support for Red Hat Linux
                redhat-lsb.x86_64 : LSB support for Red Hat Linux

                Then, I tried to install redhat-lsb-3.2-7.fc13.x86_64.rpm

                # rpm -Uvh redhat-lsb-3.2-7.fc13.x86_64.rpm
                error: Failed dependencies:
                /bin/gettext is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/ar is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/at is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/batch is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/bc is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/foomatic-rip is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/gs is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/lp is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/lpr is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/m4 is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/make is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/msgfmt is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/patch is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/pax is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/strip is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/bin/time is needed by redhat-lsb-3.2-7.fc13.x86_64
                /usr/sbin/sendmail is needed by redhat-lsb-3.2-7.fc13.x86_64
                libGL.so.1()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libQtCore.so.4()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libQtGui.so.4()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libQtNetwork.so.4()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libQtOpenGL.so.4()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libQtSql.so.4()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libQtSvg.so.4()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libQtXml.so.4()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libasound.so.2()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                libqt-mt.so.3()(64bit) is needed by redhat-lsb-3.2-7.fc13.x86_64
                rpmlib(FileDigests) <= 4.6.0-1 is needed by redhat-lsb-3.2-7.fc13.x86_64
                rpmlib(PayloadIsXz) <= 5.2-1 is needed by redhat-lsb-3.2-7.fc13.x86_64
                [root@slice56603 ~]#


                Could you tell me the right package I need to install for mailx on 64bit RHEL5.

                Thanks,
                Kavitha
                • 5. Re: Mailx command not found
                  506787
                  just:
                  yum install redhat-lsb
                  yum is a blessing. only touch rpm if it's necessary!