1 Reply Latest reply: Jan 9, 2010 9:28 AM by Jay SenSharma MiddlewareMagic RSS

    HttpSessionDebug  in weblogic-diagnostics.xml Is Not Working

    Jay SenSharma MiddlewareMagic
      Hi,

      I want to Analyze the HttpSession Payload (Size) in the AdminConsole-->Diagnostics-->Log Files -->EventsDataArchive

      I am using "MyDiagnosticEar\META-INF\weblogic-diagnostics.xml" as following:

      <?xml version="1.0" encoding="UTF-8"?>
      <wldf-resource xmlns="http://www.bea.com/ns/weblogic/90/diagnostics">
      <instrumentation>
      <enabled>true</enabled>
      <wldf-instrumentation-monitor>
      <name>HttpSessionDebug</name>
      <enabled>true</enabled>
      </wldf-instrumentation-monitor>
      </instrumentation>
      </wldf-resource>

      ------------
      I am using a Simple JSP page to set Some Attribute inside the newly Created Session
      MyDiagnosticEar\SimpleActionWebApp\index.jsp


      <%@ page language="java" contentType="text/html;charset=UTF-8"%>
      <%@ page session="false" %>
      <html>
      <body>
      <%
      HttpSession session=request.getSession(true);
      out.println("<h4>Session ID: "+session.getId());
      session.setAttribute("AAAAAAAAA","BBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBB");
      java.util.Vector v=new java.util.Vector();
      v.add(new java.util.Date());
      v.add(new java.util.ArrayList());
      v.add("AAAAABBCCCC");
      session.setAttribute("EEEEEEEEEEEEEE",v);
      %>
      <BR> Data is Set As an Attribute inside the HttpSession:
      <BR>
      session.setAttribute("AAAAAAAAA","BBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBBB");
      <BR>
      session.setAttribute("EEEEEEEEEEEEEE",v);
      <%
      System.out.println((String)request.getSession().getAttribute("AAAAAAAAA"));

      System.out.println(session.getAttribute("EEEEEEEEEEEEEE"));
      %>
      </body>
      </html>
      --------------

      Please let me know if there is any thing missing.....I have tested it in All WLS9.2, WLS10MP1 and WLS10.3 versions ..But no Success...

      I am not able to see anything After hitting the JSP...in AdminConsole-->Diagnostics-->Log Files -->EventsDataArchive
      But i can see that the Diagnostic Module has been Picked up successfully...

      AdminConsole--->Deployments--->MyDiagnosticEar -->Configuration--->Instrumentation page

      Thanks
      Jay SenSharma

      Edited by: Jay SenSharma on Jan 7, 2010 4:56 PM

      Edited by: Jay SenSharma on Jan 19, 2010 12:00 AM