10 Replies Latest reply: Jan 28, 2010 11:20 AM by user596857 RSS

    Oracle R12 apps install fails, HTTP has no libdb.so.2

    user596857
      Dear Experts,

      Once again, I attempted to install Oracle apps R12.
      At least the third time now.

      And again, the database installed, but the front end did not.


      From the final checks.
      checking URL = http://blue.gateway.2wire.net:8003

      RW-50015: Error: - HTTP Listener is not responding. The service might not have started on the port yet. Please check the service and use the retry button.
      Help Page



      I checked the status:


      cd /oappsdata/VIS/inst/apps/VIS_blue/admin/scripts
      ./adapcctl.sh status



      You are running adapcctl.sh version 120.7.12010000.2

      Checking status of OPMN managed Oracle HTTP Server (OHS) instance ...

      Processes in Instance: VIS_blue.blue.gateway.2wire.net
      --------------------------------------------------------------+---------
      ias-component | process-type | pid | status
      --------------------------------------------------------------+---------
      OC4JGroup:default_group | OC4J:oafm | 14555 | Alive
      OC4JGroup:default_group | OC4J:forms | 14490 | Alive
      OC4JGroup:default_group | OC4J:oacore | 14410 | Alive
      HTTP_Server | HTTP_Server | N/A | Down


      adapcctl.sh: exiting with status 0

      adapcctl.sh: check the logfile
      /oappsdata/VIS/inst/apps/VIS_blue/logs/appl/admin/log/adapcctl.txt
      for more information ...


      ---------------------------------------------------
      Check the file it mentions:

      cat /oappsdata/VIS/inst/apps/VIS_blue/logs/appl/admin/log/adapcctl.txt

      01/23/10-14:52:35 :: adapcctl.sh version 120.7.12010000.2
      01/23/10-14:52:35 :: adapcctl.sh: starting OPMN if it is not running

      opmnctl: opmn is already running.

      01/23/10-14:52:35 :: adapcctl.sh: starting OPMN managed OHS instance

      opmnctl: starting opmn managed processes...
      ================================================================================
      opmn id=blue.gateway.2wire.net:6203
      0 of 1 processes started.

      ias-instance id=VIS_blue.blue.gateway.2wire.net
      ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      --------------------------------------------------------------------------------
      ias-component/process-type/process-set:
      HTTP_Server/HTTP_Server/HTTP_Server/

      Error
      --> Process (index=1,uid=1636906973,pid=14378)
      failed to start a managed process after the maximum retry limit
      Log:
      /oappsdata/VIS/inst/apps/VIS_blue/logs/ora/10.1.3/opmn/HTTP_Server~1.log


      01/23/10-14:52:39 :: adapcctl.sh: exiting with status 204

      ================================================================================


      01/23/10-17:12:52 :: adapcctl.sh version 120.7.12010000.2
      01/23/10-17:12:52 :: adapcctl.sh: checking status of OPMN managed OHS instance


      Processes in Instance: VIS_blue.blue.gateway.2wire.net
      --------------------------------------------------------------+---------
      ias-component | process-type | pid | status
      --------------------------------------------------------------+---------
      OC4JGroup:default_group | OC4J:oafm | 14555 | Alive
      OC4JGroup:default_group | OC4J:forms | 14490 | Alive
      OC4JGroup:default_group | OC4J:oacore | 14410 | Alive
      HTTP_Server | HTTP_Server | N/A | Down


      01/23/10-17:12:54 :: adapcctl.sh: exiting with status 0

      ================================================================================


      ---------------------------------------------------
      Check the log it mentions:

      cat /oappsdata/VIS/inst/apps/VIS_blue/logs/ora/10.1.3/opmn/HTTP_Server~1.log


      10/01/23 14:52:35 Start process
      --------
      /oappsdata/VIS/inst/apps/VIS_blue/ora/10.1.3/Apache/Apache/bin/apachectl startssl: execing httpd
      /oappsdata/VIS/apps/tech_st/10.1.3/Apache/Apache/bin/httpd: error while loading shared libraries: libdb.so.2: cannot open shared object file: No such file or directory

      --------
      10/01/23 14:52:37 Start process
      --------
      /oappsdata/VIS/inst/apps/VIS_blue/ora/10.1.3/Apache/Apache/bin/apachectl startssl: execing httpd
      /oappsdata/VIS/apps/tech_st/10.1.3/Apache/Apache/bin/httpd: error while loading shared libraries: libdb.so.2: cannot open shared object file: No such file or directory



      --------------

      So, it is missing file: libdb.so.2

      I cannot find any such file, "libdb.so.2", on the entire server.

      find / -type f | grep -i "libdb.so.2"
      -nothing

      find / -type f | grep -i "libdb.so"
      - nothing




      find / -type f | grep -i "libdb"
      /lib/libdbus-1.so.3.2.0
      /lib/libdb_cxx-4.2.so
      /lib/libdb-4.2.so
      /lib/libdb-4.1.so
      /lib/libdb_cxx-4.1.so
      /lib/libdb-4.3.so
      /oappsinstall/startCD/Disk1/rapidwiz/jre/IBM_AIX/1.6.0/lib/ppc/libdbx_j9.so
      /oappsdata/VIS/db/tech_st/11.1.0/lib/libdbcfg11.so
      /oappsdata/VIS/db/tech_st/11.1.0/rdbms/lib/libdbtools11.a
      /oappsdata/VIS/db/tech_st/11.1.0/srvm/lib/libdbcfg11.a
      /oappsdata/VIS/apps/tech_st/10.1.2/inventory/filemap/rdbms/lib/libdbtools10.a/files.map
      /oappsdata/VIS/apps/tech_st/10.1.2/rdbms/lib/libdbtools10.a
      /oappsdata/VIS/apps/tech_st/10.1.2/.patch_storage/7379122/rdbms/lib/impdta.o_libdbtools10.a_pre_7379122
      /oappsdata/VIS/apps/tech_st/10.1.2/.patch_storage/7379122/rdbms/lib/impdrv.o_libdbtools10.a_pre_7379122
      /oappsdata/VIS/apps/tech_st/10.1.2/.patch_storage/5651245/rdbms/lib/ulmai.o_libdbtools10.a_pre_5651245
      /oappsdata/VIS/apps/apps_st/appl/msd/12.0.0/patch/115/sql/MSDNEWLIBDB.sql
      /oappsdata/VIS/apps/apps_st/appl/msd/12.0.0/patch/115/sql/MSDRETLIBDBNAME.sql
      /oappsdata/VIS/apps/apps_st/appl/gl/12.0.0/patch/115/sql/glibdbts.pls
      /oappsdata/VIS/apps/apps_st/appl/gl/12.0.0/patch/115/sql/glibdbtb.pls
      /usr/lib/libdbi.so.0.0.5
      /usr/lib/mysql/libdbug.a
      /usr/lib/libdb_cxx-4.3.so
      /usr/lib/dbd/libdbdmysql.so
      /usr/lib/dbd/libdbdpgsql.so
      /usr/lib/dbd/libdbdpgsql.la
      /usr/lib/dbd/libdbdmysql.la
      /usr/lib/dbd/libdbdpgsql.a
      /usr/lib/dbd/libdbdmysql.a
      /usr/lib/libdb-4.3.a
      /usr/lib/libdb-4.3.la
      /usr/lib/xulrunner-1.9pre/components/libdbusservice.so
      /usr/lib/libdb_cxx-4.3.la
      /usr/lib/libdb_cxx-4.3.a
      /usr/lib/xorg/modules/extensions/libdbe.so
      /usr/lib/libdbus-glib-1.so.2.0.0
      /usr/share/doc/libdbi-0.8.1/AUTHORS
      /usr/share/doc/libdbi-0.8.1/COPYING
      /usr/share/doc/libdbi-0.8.1/ChangeLog
      /usr/share/doc/libdbi-0.8.1/README
      /usr/share/doc/libdbi-drivers-0.8.1a/AUTHORS
      /usr/share/doc/libdbi-drivers-0.8.1a/COPYING
      /usr/share/doc/libdbi-drivers-0.8.1a/ChangeLog
      /usr/share/doc/libdbi-drivers-0.8.1a/README




      Does anyone have a solution?
      A package perhaps?
      Or a symbolic link?


      Thanks a lot!