7 Replies Latest reply: Dec 3, 2010 3:35 PM by paker RSS

    JDeveloper Hangs on startup!?

    755018
      Hi All,

      ive been using v10 of jdeveloper for a while and have just upgraded but it seems not to like my laptop!

      when jdeveloper first starts up it is responsive for around 10 secs and then it just freezes, when i check the task manager it shows its using 50% of my cpu with 180MB of ram. can someone help me get this problem sorted? my laptop if a dual core system with 4Gb of ram so i dont think its a spec issue!

      ive tried to read up onit and people are saying play with the values in the jdev.conf and ide.conf to get it to work but playing with these values havent really helped. their contents are:

      jdev.conf
      ==============================================
      SetJavaHome C:\Program Files\Java\jdk1.6.0_18
      AddVMOption -XX:MaxPermSize=256M

      ..rest are default entries..

      ide.conf
      ==============================================
      AddVMOption -Xmx512M
      AddVMOption -Xms128M

      .. rest are default entries...


      any help is greatly appretiated.

      Thanks
        • 1. Re: JDeveloper Hangs on startup!?
          Shay Shmeltzer-Oracle
          Try running the jdev/bin/jdev.exe file and watch the DOS window to see if you are getting any exceptions.
          • 2. Re: JDeveloper Hangs on startup!?
            755018
            I ran that executable and nothing was displayed in the dos window at all, there was only a blinking cursor.
            • 3. Re: JDeveloper Hangs on startup!?
              Shay Shmeltzer-Oracle
              Can you remove the system directory (under the [jdev-root]\jdev directory)
              and try again.
              • 4. Re: JDeveloper Hangs on startup!?
                695332
                hi i fight with this issue in the past and i have a solution but can not work fine

                1.- in the jdev.conf need to manage same memory in ide.conf if yo work with 4gb of ram i recomend a 1024 of max memory
                jdev.conf
                ==============================================
                SetJavaHome C:\Program Files\Java\jdk1.6.0_18
                AddVMOption -XX:MaxPermSize=1024M

                ide.conf
                ==============================================
                AddVMOption -Xmx1024M
                AddVMOption -Xms512M

                2.- update your jdk of the machine not the jdeveloper (backup can be helpful)
                3.- set the java home to the new directory (#:/Programs files/Java/jdk 6.x.x) in the jdev.conf have a variable "# SET_JAVA_HOME = /Jdev/bin/jdk"
                if show with "#" in start the of instruction remove
                4.- (Optional) can be show in start jdeveloper to define the directory, sometimes.

                if still not working add "#" in "SET_JAVA_HOME" to define defalut jdk and play with memory defined in jdev.conf
                • 5. Re: JDeveloper Hangs on startup!?
                  755018
                  I have tried that, i foind if i used the 1024M option i kept getting errors so i put it to 768 and it works. jdev now runs ok and i can click on the menu and set preferences but when ever i go to edit a java class file it freezes again and i have to kill the process!?

                  is jdev 11 really this buggy?

                  Edited by: user9510576 on 19-Feb-2010 12:53
                  • 6. Re: JDeveloper Hangs on startup!?
                    paker
                    Have the same problem!
                    did you find a workaround?

                    thanks!
                    Francisco
                    • 7. Re: JDeveloper Hangs on startup!?
                      paker
                      Well, I've workarounded it.
                      It seems that the problem was with the migrated project (from 10 to 11).
                      So, I've generated a new project from a working war archve, and that was it.

                      I hope it works for you too!

                      Francisco.