1 Reply Latest reply: Feb 27, 2010 2:08 AM by 749391 RSS

    ORA-12638: Credential retrieval failed

    749391
      Hi all.
      I miss any possibilities to solve my problem. I delete my Oracle 11gr1, than I tried to reinstall it. And software is installed well, but when I tried to create DB by Database Configuration Assistant it show me an error "ORA-12638: Credential retrieval failed". If I tried to install with parameter
      SQLNET.AUTHENTICATION_SERVICES= (NONE) it tells me after creation of DB that listener is not run.

      Any way, I want to solve first problem, firstly.

      Last step was reinstall my OS (Windows 2003 Server 64), so it is quite clear now, but I have got the same error.

      Help, please.
      Thanks,
      Anton.
        • 1. Re: ORA-12638: Credential retrieval failed
          749391
          I solve my problem by my self. Here is description of solution, hopefully it will be useful for somebody...

          I did no write here full start information.
          So I have:

          OS: Windows Server 2003 r2 64-bit
          DB: Oracle 11G R1

          Server is remote ! So I connected to it by remote desktop. My account is in administrative grope, as well in ORA_DBA group.

          Problem was in error during creation database, after installation oracle soft: ORA-12638: Credential retrieval failed.

          Solution is: I created local user, put it into administration and ORA_DBA group and after that run creation DB under this user. I used follow script:

          runas /user:bakeoff-srv-2\petroant "F:\oracle\product\11.1.0\db_1\BIN\launch.exe F:\oracle\product\11.1.0\db_1\assistants\dbca dbca.cl"

          and run it in cmd.

          Good luck for all.