This discussion is archived
9 Replies Latest reply: Feb 18, 2013 7:02 AM by JuliánIsaza RSS

Weblogic 10.3 console not available on AIX 6.1

746231 Newbie
Currently Being Moderated
Hi,

I have Weblogic 10.3 installed on AIX 6.1 platform
java application working with java6 SR 4 of IBM.

Application contains 2 ears,
Once i trying to start server with both ears deployed i recieve following error on one of ears:
<Mar 1, 2010 10:57:31 AM IST> <Error> <Deployer> <BEA-149205> <Failed to initialize the application 'AMSSFullServer_ECare_weblogic' due to error weblogic.application.ModuleException: Failed to load webapp: '/sts'.weblogic.application.ModuleException: Failed to load webapp: '/sts'
caused by
java.util.zip.ZipException: error in opening zip file

ear failed to start, but i am able to open console.

Once i remove second ear from configuration via console or from config.xml this problematic ear starting successfully without any problem.
Unfortunatly in this case i am not able anymore to open console.
Following error appears in this case.

+<Mar 1, 2010 4:18:17 PM IST> <Error> <J2EE> <BEA-160001> <Error deploying Internal Application: weblogic.application.ModuleException: Failed to load webapp: 'console'+
weblogic.application.utils.StateChangeException: weblogic.application.ModuleException: Failed to load webapp: 'console'
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:45)
at weblogic.application.internal.BackgroundDeploymentService$BackgroundDeployAction.run(BackgroundDeploymentService.java:271)
at weblogic.application.internal.BackgroundDeploymentService$OnDemandBackgroundDeployAction.run(BackgroundDeploymentService.java:334)
at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:516)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
Truncated. see log file for complete stacktrace
weblogic.application.ModuleException: Failed to load webapp: 'console'
at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:387)
at weblogic.application.internal.flow.ScopedModuleDriver.prepare(ScopedModuleDriver.java:176)
at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:93)
at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:387)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:37)
Truncated. see log file for complete stacktrace
java.lang.NullPointerException
at weblogic.servlet.internal.ConsoleExtensionManager.applyExtensionConfigFile(ConsoleExtensionManager.java:231)
at weblogic.servlet.internal.ConsoleExtensionManager.findExtensions(ConsoleExtensionManager.java:88)
at weblogic.servlet.internal.War.processExtensions(War.java:732)
at weblogic.servlet.internal.War.init(War.java:245)
at weblogic.servlet.internal.War.<init>(War.java:211)
Truncated. see log file for complete stacktrace
+>+
+<Mar 1, 2010 4:18:18 PM IST> <Error> <HTTP> <BEA-101093> <Problem occurred while dispatching servlet request.+
weblogic.management.DeploymentException:
at weblogic.application.internal.BackgroundDeploymentService.OnDemandURIAccessed(BackgroundDeploymentService.java:164)
at weblogic.servlet.internal.OnDemandManager.loadOnDemandURI(OnDemandManager.java:106)
at weblogic.servlet.internal.MuxableSocketHTTP.dispatch(MuxableSocketHTTP.java:335)
at weblogic.socket.MuxableSocketDiscriminator.dispatch(MuxableSocketDiscriminator.java:175)
at weblogic.socket.SocketMuxer.readReadySocketOnce(SocketMuxer.java:917)
Truncated. see log file for complete stacktrace
java.lang.NullPointerException
at weblogic.servlet.internal.ConsoleExtensionManager.applyExtensionConfigFile(ConsoleExtensionManager.java:231)
at weblogic.servlet.internal.ConsoleExtensionManager.findExtensions(ConsoleExtensionManager.java:88)
at weblogic.servlet.internal.War.processExtensions(War.java:732)
at weblogic.servlet.internal.War.init(War.java:245)
at weblogic.servlet.internal.War.<init>(War.java:211)
Truncated. see log file for complete stacktrace

In case of Sun, HP or Linux OS's we have no issue with this application.
Please advice, what can cause such behavior.


P.S. following patches of Weblogic installed
Patch ID: 4ZUY
Patch ID: I52N
Patch ID: U9QQ

Thanks,
Michael Fiskin

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points