1 2 Previous Next 20 Replies Latest reply: Mar 24, 2010 9:09 AM by 749005 RSS

    AIA Installation fails at Step 10 of 11

    749005
      Hi,
      I installed Oracle Enterprise Repository and tried installing the AIA 3.0 on top of it. When i tried to start the SOA Server from shell, the server started. but when i tried to start from Admin console, the server failed to start. I workaround it by placing the boot.properties file in the <domain>\server\soa_server1\security\.
      The server started but the status was TASK IN PROGRESS even after Task completion.

      The installation of AIA failed at Deploy application configurations.

      The error is as follows:
      ===========================================
      Retrying Configuration Step
      ===========================================
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/EboDesigner/sql/AIA.30.Pristine.Seed_Data.sql
      [sql] 49927 of 49927 SQL statements executed successfully
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/EboDesigner/sql/createEBODesignerProcedures.sql
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/EboDesigner/sql/AIA.30.Pristine.Clob.Seed_Data.sql
      [sql] 2 of 2 SQL statements executed successfully
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/LifeCycle/sql/Common_DB_Script.sql
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/LifeCycle/sql/OER_DB_Script.sql
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/LifeCycle/sql/Composite_DB_Script.sql
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/LifeCycle/sql/Deploy_DB_Script.sql
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/LifeCycle/sql/createLifecycleProcedures.sql
      [sql] 5 of 5 SQL statements executed successfully
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/LifeCycle/sql/SeedData.sql
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/LifeCycle/sql/DeploySeedData.sql
      [sql] 251 of 251 SQL statements executed successfully
      [sql] Failed to execute:
      [sql] Executing resource: /app/oracle/Middleware/Oracle_SOA1/rcu/integration/soainfra/sql/xref/createschema_xref_oracle.sql
      [sql] 7 of 8 SQL statements executed successfully
      [sql] Executing resource: /app/oracle/Middleware/AIAFP3/Infrastructure/Install/seeddata/sql/MSG_RESUBMIT.sql
      [sql] 1 of 1 SQL statements executed successfully
      [delete] Deleting directory /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/tempMetadata
      [sql] Rem
      [sql] Rem $Header: pcbpel/admin/sql/xref/createschema_xref_oracle.sql /main/9 2009/05/21 00:28:38 vboyidap Exp $
      [sql] Rem
      [sql] Rem createschema_xref_oracle.sql
      [sql] Rem
      [sql] Rem Copyright (c) 2006, 2009, Oracle and/or its affiliates.
      [sql] Rem All rights reserved.
      [sql] Rem
      [sql] Rem NAME
      [sql] Rem createschema_xref_oracle.sql - Create Cross Reference Tables
      [sql] Rem
      [sql] Rem DESCRIPTION
      [sql] Rem Creates the Cross Reference Table required for
      [sql] Rem supporting cross Reference feature out of the box.
      [sql] Rem
      [sql] Rem NOTES
      [sql] Rem <other useful comments, qualifications, etc.>
      [sql] Rem
      [sql] Rem MODIFIED (MM/DD/YY)
      [sql] Rem vboyidap 10/01/08 - fixing bug 7424654 change index on row_number to
      [sql] Rem reverse index
      [sql] Rem vboyidap 04/01/08 - Bug#6799400 - changed the sql type of LAST_MODIFED from VARCHAR2 to TIMESTAMP
      [sql] Rem vboyidap 10/06/06 - Adding indexes on ROW_NUMBER and VALUE
      [sql] Rem mahnaray 10/08/06 -
      [sql] Rem sanjain 09/08/06 -
      [sql] Rem mahnaray 08/24/06 - Created
      [sql] Rem
      [sql]
      [sql] DROP INDEX XREF_ROW_NUMBER
      [sql] java.sql.SQLSyntaxErrorException: ORA-00900: invalid SQL statement
      [mkdir] Created dir: /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/tempMetadata
      [copy] Copying 3501 files to /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/tempMetadata/AIAMetaData
      [copy] Copied 3742 empty directories to 4 empty directories under /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/tempMetadata/AIAMetaData
      [delete] Deleting: /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/MetaData.jar
      [jar] Building jar: /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/MetaData.jar
      [delete] Deleting: /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/MetaData.zip
      [zip] Building zip: /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/MetaData.zip
      [echo] oracle.home = /app/oracle/Middleware/Oracle_SOA1/bin/..

      deploy:
      [input] skipping input as property serverURL has already been set.
      [input] skipping input as property sarLocation has already been set.
      [deployComposite] setting user/password..., user=weblogic
      [deployComposite] Processing sar=/app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/AIAMetaData/MetaData.zip
      [deployComposite] created temp dir =/tmp/deploy_client_1267620211708
      [deployComposite] Adding shared data file - /tmp/deploy_client_1267620211708/MetaData.jar
      [deployComposite] Creating HTTP connection to host:hydhtc70560d, port:8001
      [deployComposite] java.net.ConnectException: Connection refused
      [deployComposite]      at java.net.PlainSocketImpl.socketConnect(Native Method)
      [deployComposite]      at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
      [deployComposite]      at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
      [deployComposite]      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
      [deployComposite]      at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
      [deployComposite]      at java.net.Socket.connect(Socket.java:519)
      [deployComposite]      at java.net.Socket.connect(Socket.java:469)
      [deployComposite]      at java.net.Socket.<init>(Socket.java:366)
      [deployComposite]      at java.net.Socket.<init>(Socket.java:209)
      [deployComposite]      at javax.net.DefaultSocketFactory.createSocket(SocketFactory.java:212)
      [deployComposite]      at HTTPClient.HTTPConnection.getSocket(HTTPConnection.java:3606)
      [deployComposite]      at HTTPClient.HTTPConnection.doConnect(HTTPConnection.java:4364)
      [deployComposite]      at HTTPClient.HTTPConnection.sendRequest(HTTPConnection.java:3358)
      [deployComposite]      at HTTPClient.HttpOutputStream.closeImpl(HttpOutputStream.java:461)
      [deployComposite]      at HTTPClient.HttpOutputStream.access$000(HttpOutputStream.java:99)
      [deployComposite]      at HTTPClient.HttpOutputStream$1.run(HttpOutputStream.java:417)
      [deployComposite]      at HTTPClient.HttpClientConfiguration.doAction(HttpClientConfiguration.java:666)
      [deployComposite]      at HTTPClient.HttpOutputStream.close(HttpOutputStream.java:415)
      [deployComposite]      at java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:149)
      [deployComposite]      at java.util.zip.ZipOutputStream.close(ZipOutputStream.java:321)
      [deployComposite]      at oracle.integration.platform.blocks.deploy.servlet.client.DeployerHttpClient.sendCompositeArchives(DeployerHttpClient.java:385)
      [deployComposite]      at oracle.integration.platform.blocks.deploy.servlet.client.DeployerHttpClient.sendRequest(DeployerHttpClient.java:307)
      [deployComposite]      at oracle.integration.platform.blocks.deploy.servlet.CompositeServletClientBase.sendRequest(CompositeServletClientBase.java:330)
      [deployComposite]      at oracle.integration.platform.blocks.deploy.servlet.client.ant.DeployCompositeTask.execute(DeployCompositeTask.java:117)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.Target.execute(Target.java:357)
      [deployComposite]      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [deployComposite]      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [deployComposite]      at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
      [deployComposite]      at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [deployComposite]      at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)

      Deployment Command Return Value Configuration: 1
      BUILD FAILED
      /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/AIAInstallDriver.xml:146: The following error occurred while executing this line:
      /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/AIAExecuteDriver.xml:102: The following error occurred while executing this line:
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/AIAExecuteDriver.xml:58: The following error occurred while executing this line:
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/tmp/AIDExecuteDP_temp_1612505650.xml:72: The following error occurred while executing this line:
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.Target.execute(Target.java:357)
      /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/lib/AIDConfigurationLibraryTasks.xml:562: The following error occurred while executing this line:
      [deployComposite]      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      progress in calculate progress20
      [deployComposite]      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      /app/oracle/Middleware/Oracle_SOA1/bin/ant-sca-deploy.xml:132: java.net.ConnectException: Connection refused
      [deployComposite]      at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)

      Total time: 4 minutes 40 seconds
      progress in calculate progress20
      [deployComposite]      at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [deployComposite]      at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:62)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:391)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.Target.execute(Target.java:357)
      [deployComposite]      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [deployComposite]      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [deployComposite]      at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
      [deployComposite]      at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [deployComposite]      at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
      [deployComposite]      at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployComposite]      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      [deployComposite]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployComposite]      at java.lang.reflect.Method.invoke(Method.java:597)
      [deployComposite]      at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployComposite]      at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployComposite]      at org.apache.tools.ant.Target.execute(Target.java:357)
      [deployComposite]      at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [deployComposite]      at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [deployComposite]      at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [deployComposite]      at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [deployComposite]      at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [deployComposite]      at org.apache.tools.ant.Main.runBuild(Main.java:698)
      [deployComposite]      at org.apache.tools.ant.Main.startAnt(Main.java:199)
      [deployComposite]      at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      [deployComposite]      at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

      Edited by: kanakavally_harilal on Mar 4, 2010 7:45 AM
        • 1. Re: AIA Installation fails at Step 10 of 11
          Rouven Degen
          Hi Kanakavally,

          you can try the following workaround.

          During the installation the server is shut down and restarted after some time.
          Wait until the server is running again and then edit the <soa_server_name>.state file manually.

          The file is located in .../Middleware/user_projects/domains/your_domain/servers/soa_server_name/data/nodemanager

          Change the content to RUNNING:Y:N

          The Status of Last action should be updated to TASK COMPLETED and then the installation should continue.

          Kind regards,
          Rouven

          Edited by: user4449381 on Mar 4, 2010 12:10 AM
          • 2. Re: AIA Installation fails at Step 10 of 11
            749005
            Hi
            I followed the steps. But the installation failed again. The server state in console is starting and the Status of Last Action is TASK Completed. Following is the error.

            [echo] eis/db/aiaB2BInfraDBCF connection instance already created in DB Adapter. Skipping this connection instance configuration
            [wlst] @@@ Starting the script ...
            [wlst] Connecting to t3://hydhtc70560d:7001 with userid weblogic ...
            [wlst] Successfully connected to Admin Server 'AdminServer' that belongs to domain 'AIADomain'.
            [wlst]
            [wlst] Warning: An insecure protocol was used to connect to the
            [wlst] server. To ensure on-the-wire security, the SSL port or
            [wlst] Admin port should be used instead.
            [wlst]
            [wlst] Location changed to edit tree. This is a writable tree with
            [wlst] DomainMBean as the root. To make changes you will need to start
            [wlst] an edit session via startEdit().
            [wlst]
            [wlst] For more help, use help(edit)
            [wlst]
            [wlst] Edit session is cancelled successfully
            [wlst] Already in Edit Tree
            [wlst]
            [wlst] Starting an edit session ...
            [wlst] Started edit session, please be sure to save and activate your
            [wlst] changes once you are done.
            [wlst] attempting to create JMS Server :AIAJMSServer
            [wlst] Error Creating JMS Server..
            [wlst] Validating changes ...
            [wlst] Validated the changes successfully
            [wlst] Saving all your changes ...
            [wlst] Saved all your changes successfully.
            [wlst] Activating all your changes, this may take a while ...
            [wlst] The edit lock associated with this edit session is released
            [wlst] once the activation is completed.
            [wlst] Activation completed
            [wlst] No stack trace available.
            [wlst] Disconnected from weblogic server: AdminServer
            [wlst] @@@ Starting the script ...
            [wlst] Connecting to t3://hydhtc70560d:7001 with userid weblogic ...
            [wlst] Successfully connected to Admin Server 'AdminServer' that belongs to domain 'AIADomain'.

            BUILD FAILED
            [wlst]
            /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/AIAInstallDriver.xml:146: The following error occurred while executing this line:
            [wlst] Warning: An insecure protocol was used to connect to the
            [wlst] server. To ensure on-the-wire security, the SSL port or
            /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/AIAExecuteDriver.xml:102: The following error occurred while executing this line:
            [wlst] Admin port should be used instead.
            [wlst]
            /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/AIAExecuteDriver.xml:58: The following error occurred while executing this line:
            [wlst] Location changed to edit tree. This is a writable tree with
            [wlst] DomainMBean as the root. To make changes you will need to start
            [wlst] an edit session via startEdit().
            /app/oracle/Middleware/AIAFP3/aia_instances/AIAFP3/tmp/AIDExecuteDP_temp_748173952.xml:99: The following error occurred while executing this line:
            [wlst]
            [wlst] For more help, use help(edit)
            /app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/lib/AIDJMSResourcesLibraryTasks.xml:127: Traceback (innermost last):
            [wlst]
            [wlst] Edit session is cancelled successfully
            [wlst] Already in Edit Tree
            File "/app/oracle/Middleware/AIAFP3/Infrastructure/Install/AID/lib/py/createJMSConnectionFactory.py", line 43, in ?
            [wlst]
            [wlst] Starting an edit session ...
            AttributeError: 'NoneType' object has no attribute 'getJMSResource'
            [wlst] Started edit session, please be sure to save and activate your

            [wlst] changes once you are done.

            Total time: 42 minutes 17 seconds
            <Mar 4, 2010 10:41:36 AM IST> <Warning> <JNDI> <BEA-050001> <WLContext.close() was called in a different thread than the one in which it was created.>
            <Mar 4, 2010 10:41:36 AM IST> <Warning> <JNDI> <BEA-050001> <WLContext.close() was called in a different thread than the one in which it was created.>
            Deployment Command Return Value Configuration: 1
            progress in calculate progress20
            progress in calculate progress20

            Edited by: kanakavally_harilal on Mar 4, 2010 7:43 AM
            • 3. Re: AIA Installation fails at Step 10 of 11
              Rouven Degen
              Hi Kanakavally,

              you have to wait until the State of the server in AdminConsole is RUNNING again.

              After the State has switched to RUNNING edit the file, not during startup of the server.

              Kind regards,
              Rouven
              • 4. Re: AIA Installation fails at Step 10 of 11
                749005
                Hi Rouven,

                I used the same approach. But when the SOA server restarts in the installation, the same is not reflected in the Admin console. And when the installation is failed, i get the server state as starting and task status as TASK COMPLETED.

                Thanks and regards
                Philip
                • 5. Re: AIA Installation fails at Step 10 of 11
                  Rouven Degen
                  Hi Kanakavally,

                  how do you start your server?

                  Do you start the soa_server1 through AdminConsole or Shell script?

                  If you start it through AdminConsole, did you check in EnterpriseManager if all Services were started, too?

                  Kind regards,
                  Rouven
                  • 6. Re: AIA Installation fails at Step 10 of 11
                    749005
                    hi,
                    Right now i hace reinstalled all the Applications including Oracle enterprise repository. I have finished all the preinstallation steps for AIA installation.
                    When i started the soa server in console, everything is starting fine.

                    But When i try to start the Soaserver in admin console, i can see services namely AQadapter and DBAdapter in deployments are in failed state and a few others are in prepared state. In em console, i can see the soa_server as down.


                    While starting the OER server i get the following warning.

                    Mar 4, 2010 7:38:05 PM oracle.as.jmx.framework.LoggerHelper log
                    WARNING: Error parsing MBean descriptor file "/app/oracle/Middleware/user_projec
                    ts/domains/AIADomain/config/fmwconfig/servers/oer_server1/mbeans/dfw_mbeans.xml"
                    +.+
                    java.lang.InstantiationException: org.apache.xerces.jaxp.DocumentBuilderFactoryI
                    mpl cannot be cast to javax.xml.parsers.DocumentBuilderFactory


                    More than four to five of such warnings appear before the status is changing to running.

                    Will these issues mentioned cause any problems in AIA installation.

                    Any help would be appreciated.

                    Regards
                    Philp
                    • 7. Re: AIA Installation fails at Step 10 of 11
                      Rouven Degen
                      Hi Philp,

                      i don't think that this has a negative impact on AIA installation.

                      But when the soa_server doesn't come up correctly in em, you should kill the process and start it through Shell script.
                      Then, this seems to have some kind of "healing".

                      After that, it should be possible to stop the soa_server and start it again through AdminConsole.

                      After the bounce of the soa_server, make sure it is displayed as running in em. Then, you can retry the AIA installation again, applying the workaround editing the .state file mentioned in previous answers.

                      Kind regards,
                      Rouven

                      Edited by: Rouven Degen on Mar 4, 2010 4:51 PM

                      Edited by: Rouven Degen on Mar 4, 2010 4:57 PM
                      • 8. Re: AIA Installation fails at Step 10 of 11
                        Rouven Degen
                        Hi,

                        it seems, the root cause of the Status of Last Action remaining in "TASK IN PROGRESS" is, that no your_server.pid file is genrated in domains/your_domain/servers/your_server/data/nodemanager directory.

                        Does anyone have a clue why this happens?

                        Kind regards,
                        Rouven


                        server_name.pid

                        server_name.pid is generated by each server and contains the process ID of the server. Node Manager checks the process ID generated by the server during crash recovery.

                        This file is located in DOMAIN_HOME/servers/<server_name>/data/nodemanager
                        server_name.state

                        server_name.state is generated by the server and contains the server’s current state. Node Manager monitors the contents of this file to determine the current state of the server.
                        Note:      Do not delete or alter this file. Without this file Node Manager cannot determine the current state of the server.

                        This file is located in DOMAIN_HOME/servers/<server_name>/data/nodemanager.

                        Edited by: Rouven Degen on Mar 4, 2010 5:06 PM
                        • 9. Re: AIA Installation fails at Step 10 of 11
                          749005
                          hi,
                          I have tried that method of Stopping the server in admin console and starting it in Console. But even after that if i try to start from admin console, i am facing the same issue. When i checked the logs i could find a lot of class not found exception. The Server takes just 47 seconds to start in admin console where as it takes 5 minutes in unix console. I basically feel that these exceptions occur due to incorrect classpath.

                          Here is the log


                          Caused By: java.lang.ClassNotFoundException: oracle.dms.wls.DMSServletFilter
                          +     at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:296)+
                          +     at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:269)+
                          +     at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:56)+
                          +     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)+
                          +     at java.lang.ClassLoader.loadClass(ClassLoader.java:252)+
                          +     Truncated. see log file for complete stacktrace+
                          +>+

                          +<Mar 4, 2010 10:41:23 PM EST> <Error> <HTTP> <BEA-101165> <Could not load user defined filter in web.xml: ServletContext@20504467[app:wsil-wls module:/inspection.wsil path:/inspection.wsil spec-version:2.5] oracle.dms.wls.DMSServletFilter.+
                          java.lang.ClassNotFoundException: oracle.dms.wls.DMSServletFilter
                          +     at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:296)+
                          +     at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:269)+
                          +     at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:56)+
                          +     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)+
                          +     at java.lang.ClassLoader.loadClass(ClassLoader.java:252)+
                          +     Truncated. see log file for complete stacktrace+
                          +>+

                          +<Mar 4, 2010 10:41:23 PM EST> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application 'wsil-wls'.+
                          weblogic.application.ModuleException:

                          +     at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1399)+
                          +     at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:460)+
                          +     at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)+
                          +     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:83)+
                          +     at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)+
                          +     Truncated. see log file for complete stacktrace+

                          Caused By: java.lang.ClassNotFoundException: oracle.dms.wls.DMSServletFilter
                          +     at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:296)+
                          +     at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:269)+
                          +     at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:56)+
                          +     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)+
                          +     at java.lang.ClassLoader.loadClass(ClassLoader.java:252)+
                          +     Truncated. see log file for complete stacktrace+
                          +>+

                          +<Mar 4, 2010 10:41:23 PM EST> <Notice> <Log Management> <BEA-170027> <The Server has established connection with the Domain level Diagnostic Service successfully.>+

                          +<Mar 4, 2010 10:41:23 PM EST> <Critical> <WebLogicServer> <BEA-000286> <Failed to invoke startup class "Audit Loader Startup Class", java.lang.ClassNotFoundException: oracle.security.audit.ajl.loader.JEEAuditLoader+
                          java.lang.ClassNotFoundException: oracle.security.audit.ajl.loader.JEEAuditLoader
                          +     at java.lang.Class.forName0(Native Method)+
                          +     at java.lang.Class.forName(Class.java:247)+
                          +     at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClass(ClassDeploymentManager.java:253)+
                          +     at weblogic.management.deploy.classdeployment.ClassDeploymentManager.access$000(ClassDeploymentManager.java:54)+
                          +     at weblogic.management.deploy.classdeployment.ClassDeploymentManager$1.run(ClassDeploymentManager.java:205)+
                          +     Truncated. see log file for complete stacktrace+
                          +>+

                          +<Mar 4, 2010 10:41:23 PM EST> <Critical> <WebLogicServer> <BEA-000286> <Failed to invoke startup class "OWSM Startup class", java.lang.ClassNotFoundException: oracle.wsm.policymanager.util.PolicyManagerStartup+
                          java.lang.ClassNotFoundException: oracle.wsm.policymanager.util.PolicyManagerStartup
                          +     at java.lang.Class.forName0(Native Method)+
                          +     at java.lang.Class.forName(Class.java:247)+
                          +     at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClass(ClassDeploymentManager.java:253)+
                          +     at weblogic.management.deploy.classdeployment.ClassDeploymentManager.access$000(ClassDeploymentManager.java:54)+
                          +     at weblogic.management.deploy.classdeployment.ClassDeploymentManager$1.run(ClassDeploymentManager.java:205)+
                          +     Truncated. see log file for complete stacktrace+


                          Thanks and regards

                          Philip

                          Edited by: kanakavally_harilal on Mar 8, 2010 5:13 AM
                          • 10. Re: AIA Installation fails at Step 10 of 11
                            Gerhard Drasch-Oracle
                            Philip,
                            have you made sure that node manager uses the shell scripts to start the managed server? If not that would explain the class not found exceptions due to the incomplete classpath.

                            To do that set the property "StartScriptEnabled=true" in the nodemanager.properties file. This file is typically located in "<MW HOME>/wlserver_10.3/common/nodemanager/".

                            Make sure to restart the node manager after this change and then restart the managed server from the admin console. The class not found exceptions should disappear then.

                            Gerhard
                            • 11. Re: AIA Installation fails at Step 10 of 11
                              749005
                              Hi,
                              The start script is enabled.
                              The following is my nodemanager.properties file.


                              DomainsFile=/app/oracle/Middleware/wlserver_10.3/common/nodemanager/nodemanager.domains+
                              LogLimit=0+
                              PropertiesVersion=10.3+
                              javaHome=/app/oracle/Middleware/jrockit_160_14_R27.6.5-32+
                              AuthenticationEnabled=true+
                              NodeManagerHome=/app/oracle/Middleware/wlserver_10.3/common/nodemanager+
                              JavaHome=/app/oracle/Middleware/jrockit_160_14_R27.6.5-32/jre+
                              LogLevel=INFO+
                              DomainsFileEnabled=true+
                              StartScriptName=startWebLogic.sh+
                              ListenAddress=+
                              NativeVersionEnabled=true+
                              ListenPort=5556+
                              LogToStderr=true+
                              SecureListener=true+
                              LogCount=1+
                              StopScriptEnabled=false+
                              QuitEnabled=false+
                              LogAppend=true+
                              StateCheckInterval=500+
                              CrashRecoveryEnabled=false+
                              StartScriptEnabled=true+
                              LogFile=/app/oracle/Middleware/wlserver_10.3/common/nodemanager/nodemanager.log+
                              LogFormatter=weblogic.nodemanager.server.LogFormatter+
                              ListenBacklog=50+


                              Thanks
                              Philip
                              • 12. Re: AIA Installation fails at Step 10 of 11
                                749005
                                hi,

                                I need a clarification on how to install Oracle Enterprise repository for AIA. Can i create the the OER in the same domain and machine as that of SOA.

                                Thanks
                                Philip
                                • 13. Re: AIA Installation fails at Step 10 of 11
                                  749005
                                  Hi,
                                  i was able to bypass the step of Deploy Application Configurations. I got the error Timezone region not found. I get this error even though the arguments has -Duser.timezone=MST in the serverstart page. I get the same error when i try to start the server from both Admin Console and unix console.

                                  if possible Please setup a call to resolve this issue.

                                  Thanks
                                  Philip

                                  Edited by: kanakavally_harilal on Mar 8, 2010 5:12 AM
                                  • 14. Re: AIA Installation fails at Step 10 of 11
                                    Arvind Srinivasamoorthy-Oracle
                                    Hi Philip,
                                    1. Can you share how you got past the issue that you were facing
                                    2. Sometimes the timezones are not recognized because they are not registered as valid timezone values in the OS
                                    Try removing the parameter altogether or try using the "+05:30" format instead.

                                    Arvind
                                    Oracle AIA
                                    1 2 Previous Next