1 2 Previous Next 21 Replies Latest reply: Mar 8, 2010 5:05 AM by 609197 RSS

    Select query over database link hanging

    609197
      Hi All,

      I have been looking all over the internet and all over this forum but i could not find the solution for my issue given below.

      There are a number of distributed databases (Oracle 10g) over a private network. Sending and receiving data amongst all the databases work fine. But when one particular database A tries to receive data from database B, it hangs and then the famous old error TNS LOST CONTACT.

      Basically, this has been implemented by creating a batchjob. This worked fine for years and now suddenly this is not working only for the two specific databases.

      It is just a simple select query being hit on the remote database. This is called through a function in the package, which builds the dynamic select query using DBMS_SQL package.

      It actually hangs when doing DBMS_SQL.PARSE ();

      The same function when called in a pl/sql block from database A, works perfectly fine and receives the required data from database B. This was tried with Oracle SQLDeveloper, TOAD and SQLPLUS.

      Things seems to be working fine, but actually unaware of the problem. I tried all the suggestions provided over the metalink also.

      Require your help urgently.

      Thanks
      Akhil.
        1 2 Previous Next