8 Replies Latest reply: Jun 9, 2011 4:34 PM by 663697 RSS

    Oracle Weblogic Portal and Oracle Portal 11g

      Apologies for the cross post between here and the Oracle Portal forum.

      Would someone be able to clarify if Oracle Portal 11g is the same as Oracle Weblogic Portal or are they completely separate products. Is Oracle Weblogic Portal just rebranded as Oracle Portal 11g?

        • 1. Re: Oracle Weblogic Portal and Oracle Portal 11g

          Oracle Portal and Oracle Weblogic Portal are different products, which have some interoperability through WSRP.

          • 2. Re: Oracle Weblogic Portal and Oracle Portal 11g
            can indicate what is the difference? Please
            • 3. Re: Oracle Weblogic Portal and Oracle Portal 11g
              I am interested to know the answer too. I seemed to remember a year ago there was documents in oracle website about rebranding weblogic portal 10.3 to be 11g. But now I can't find anywhere to mention about weblogic portal 11g.
              Also where can I download weblogic portal 10.3.2? I can't find in Download section or E-Delivery. BTW I am planing to upgrade to WLP10.3.2.
              • 4. Re: Oracle Weblogic Portal and Oracle Portal 11g
                It would probably be best to start off reading the marketing materials and data sheets for each product:

                Oracle Portal: http://www.oracle.com/technetwork/middleware/portal/overview/index.html
                Oracle WebLogic Portal: http://www.oracle.com/technetwork/middleware/weblogic-portal/overview/index.html

                Those pages have links to lots of information, including the download links.
                • 5. Re: Oracle Weblogic Portal and Oracle Portal 11g
                  Thank you. Got the download. In reading the upgrade guide, it states that autonomy search needs the license from Autonomy in 10.3.2. What's the latest version has autonomy? Does 10.3.2 install bundled with autonomy at all? I need the search. Thanks.
                  • 6. Re: Oracle Weblogic Portal and Oracle Portal 11g
                    WLP 10.3.2 does not bundle the autonomy binaries. I believe you can get them from www.autonomy.com when you get a license for autonomy. Or, you can get Oracle Secure Enterprise Search and hook that up. I haven't done this myself, so I don't know any of the details. Note this is for full text-indexed search -- you do get some level of search support directly from the WLP content APIs and whatever content repository you use.

                    I believe WLP 10.3.0 does include autonomy binaries. You can download that from edelivery (Oracle BEA product pack, in the Oracle Application Server 10g Release 3 (10.1.3) Media Pack).

                    • 7. Re: Oracle Weblogic Portal and Oracle Portal 11g
                      When I tried http://www.oracle.com/technetwork/middleware/weblogic-portal/documentation/index.html, the top one is "Oracle WebLogic Portal Online Documentation Library 10g Release 3 (10.3.2)" and I am assuming that is the latest version. But when I click "View Library" of the second one, it brought me to the old BEA documentation "Oracle WebLogic Portal ® 10g Release 3 (10.3)". So both of them are labeled "10g Release 3". But the (10.3) has autonomy bundled. I don't see 10.3.0 version.
                      If I install both versions, then I can have autonomy binaries there. Since autonomy is fairly independent, even I upgrade WLP later I can still continue use autonomy?
                      • 8. Re: Oracle Weblogic Portal and Oracle Portal 11g
                        Yes, that documentation pages shows links for both WLP 10.3.2 (the lastest version, which doesn't have autonomy bundled) and WLP 10.3.0 (the previous version, which does have autonomy bundled). "10g Release 3" is larger Fusion MiddleWare release name, and you should just ignore it. Look at the 10.3.2 vs. 10.3.0 numbers -- those are the important numbers.

                        I don't know if you can use the WLP 10.3.0 autonomy binaries with a 10.3.2 server. I've never tried and I don't know if the autonomy version from 10.3.0 would work with what the documentation says is required by the 10.3.2 sample code (which is autonomy 4.6).