14 Replies Latest reply: May 20, 2013 7:49 AM by user11394989 RSS

    Error: Oracle Forms Designer has stopped working

    758704
      I have read a lot of different responses regarding this and related issues but none of the answers seem to be relative to my specific problem. Here is what I have done so far:
      a. I just finished loading Oracle 11g 64x enterprise on my laptop running windows 7. It loaded correctly and I was able to import my 10g data dump and set up my schema.
      b. I then installed the Oracle development suite: ds_windows_x86_101202_disk1 and disk2. There were some minor issues regarding compatibility but following the advise of one post, I checked the blocks in question and the software loaded fine.
      c. I also attempted to install the p5969392_10123_WINNT.zip file but it gave a message indicating that no updates applied. (I am not sure if this is the correct patch or not?)
      d. I also had to download and install the Sun SDK, v6.18.
      e. I also updated the ORACLE paths in the default.env and registry entries and tried different urls in the runtime preference block. Nothing helped and I stayed with the default.

      Oracle Forms seems to startup correctly and I am able to connect to the database with no problem. Although I did not build a new form completely, it appears that this would be no problem.

      The problem:
      The problem is that when I attempt to open a form that was previously developed in 10g on XP, I immediately get the "Oracle Forms Designer has stopped working" error and Forms Builder shuts down. I get the same error whether I attempt to open a library, menu, or form.
      I have tried changing the compatibility mode from XP, service pack 3 (the default after install) to XP, service pack 2 but it made no difference.

      If anyone has been able to work through this issue, please let me know how. Thanks