5 Replies Latest reply on Mar 19, 2010 7:54 PM by liyubo

    BI Publisher Template Builder logon error

    Rui Leandro
      Hi,

      When I'm trying to logon in the Template Builder (Microsoft Word > Add-ins menu > IOracle BI Publisher > Logon), I receive this error:

      Error while trying to access Report Server Location: The remote server returned an error: (407) Proxy Authentication Required.
      Report Server Location is: http://10.163.129.86:9704/xmlpserver/

      I've been through the Doc ID 749301.1 (Cannot connect to BI Publisher Desktop from MS Word) and Bug 6774492 (UNABLE TO CONNECT TO BI PUBLISHER EE FROM MS WORD DOC WITH BI PLUG-IN), did the configurations suggested, but still have the logon error.

      I use the same link to open the BI Publisher login page and it works fine.
      I've also tested IP+port with telnet and it responds.


      Can you please help me troubleshooting this?


      Thanks in advance,
      Rui
        • 1. Re: BI Publisher Template Builder logon error
          Rui Leandro
          Hi,

          This issue was related, obviously, with accessing BIP through the proxy.

          The BI Publisher Desktop (aka Template Builder, aka Word/Excel add-in) uses the IE configuration.
          When configuring IE, be careful to add the BI Publisher server to the proxy exceptions, or you will receive this error when trying to log in through Word add-in:

          "Error while trying to access Report Server Location: The remote server returned an error: (407) Proxy Authentication Required."

          To configure IE, follow this steps:
          1) Open IE, and navigate to Tools menu > Internet Options > Connections tab > LAN settings
          2) Configure the proxy settings for you local network. Example:
          - check "Use a proxy server..."
          - add the proxy hostname and port to the address/port fields
          - check "Bypass proxy server for local addresses
          3) Open Advanced (button)
          4) In Exceptions textbox, add the base URL/host used for accessing the BIP Server. For example, if your BIP Server URL is *http://myBipServer:9704/xmlpserver/*, then add this to the exceptions: *myBipServer*


          Also, if you're using Siebel Security, must login with upercase username. With lowercase it doesn't work.


          Bye,
          Rui Leandro

          Edited by: Rui Leandro on Mar 11, 2010 9:20 AM
          • 2. Re: BI Publisher Template Builder logon error
            Rui Leandro
            Hope this helps anyone...
            • 3. Re: BI Publisher Template Builder logon error
              liyubo
              Hi, I did check the poxy setting, and can confirm my proxy is correct. But still have same problem when I login from Word. Any other thought?
              • 4. Re: BI Publisher Template Builder logon error
                Rui Leandro
                Hi,

                Try uppercase login instead of lowercase. If you're using Siebel Security authentication, that is mandatory.
                You can also check the client software version, and confirm that it is the same as the BIP server version. If it's not, it might be necessary to upgrade the client.
                Another thing is to check if you have connectivity to the BIP server. Use the command: telnet «BIP_host» «BIP_port(9704?)». If you can't reach it, them there must be a firewall, proxy or other system blocking (check anti-virus and client firewalls, if you have any... some of them block network ports).

                In my project, we had all those issues... and in all of them it was impossible to login.

                If none of the above resolves your problem, please post your exact error message.



                Byes,
                Rui
                • 5. Re: BI Publisher Template Builder logon error
                  liyubo
                  liyubo wrote:
                  Hi, I did check the poxy setting, and can confirm my proxy is correct. But still have same problem when I login from Word. Any other thought?
                  My problem get solved. Mine is not caused by proxy. I used non-standard BI Publisher server name other than 'xmlpserver'. This do require extra configuration. Please see metalink doc: *857482.1*

                  For these who doesn't have metalink, I paste solution here:

                  Edit $BIP_DOMAIN/<bip server name>/WEB-INF/web.xml, modify following 'xmlpserver' to fit for your own bip server name:

                  -----
                  <init-param>
                  <!-- This is the root webdir for the xmlpserver application. Modify this
                  if xmlpserver.ear is not deployed to its standard location.
                  -->
                  <param-name>xmlp-online-web-dir</param-name>
                  *<param-value>/xmlpserver</param-value>*
                  </init-param>

                  <init-param>
                  <!-- Path to the ServiceGateway SOAP end point. Most likely this will be
                  the path for services deployed with Axis.
                  -->
                  <param-name>service-endpoint</param-name>
                  *<param-value>/xmlpserver/services/ServiceGateway</param-value>*
                  </init-param>

                  <init-param>
                  <!-- Path to report service web directory.
                  -->
                  <param-name>web-dir</param-name>
                  *<param-value>/xmlpserver/report_service</param-value>*
                  </init-param>
                  -----
                  1 person found this helpful