9 Replies Latest reply on Mar 30, 2010 8:15 AM by -K-

    ORA-17008 error message

      Hello users, I'm having a connection problem in SQL Developer and am not able to run any queries on the SQL worksheet.
      I get either a popup window with the following ORA-17008 error message:
      "An error was encountered performing the requested operation"
      Closed Connection
      Vendor code 17008
      Or this msg on the Script Output window: "SQL Error: No more data to read from socket"
      I've been using SQL Developer for months now and this is the first time I encounter this problem. I ran the same queries last week
      succesfully so this is not a syntax issue. I'm using version with a Basic connection.
      Does anybody know how to fix this? so far I haven't found any solutions. Thanks,
        • 1. Re: ORA-17008 error message
          This just sounds like your connection to the database has been lost and you simply need to reconnect. I have only seen this when I have left SQL Developer connected to a DB that is restarted.

          • 2. Re: ORA-17008 error message
            Being badly disconnected causes this, also when e.g. killing a remote debug.
            As theFurryOne pointed out, disconnecting and reconnection should solve it.

            • 3. Re: ORA-17008 error message
              Thanks for your quick responses. I tried disconnecting and connecting back several times. I also logged on and off several times
              and kept getting the same error. No debugging yet. Any other ideas?
              • 4. Re: ORA-17008 error message
                What DB version is that on? Can you connect with other tools like SQL*Plus?

                • 5. Re: ORA-17008 error message
                  Yes, I am able connect to SQL*Plus and run queries on it. The version is BTW, I uninstalled SQL Developer and installed the latest version (
                  and I still have the same problem. What do you think could be causing this?
                  • 6. Re: ORA-17008 error message
                    Strange. Can you try a TNS type connection? And/or check Preferences - Database - Advanced - Use OCI?

                    • 7. Re: ORA-17008 error message
                      I saw a similar problem once on a completely different application running on an IBM AIX box with IPv6 enabled by default, it was related to a problem in the JDBC driver which could not handle really well connections with IPv6 and it was solved by disabling the IPv6 features of the OS.

                      Please post your OS details, and while you are at it you can try disabling IPv6 if you have recently turned it on.

                      If you are in a hurry you can switch from JDBC based connection to OCI, but you will need to install an 11G client (or instant client).
                      • 8. Re: ORA-17008 error message
                        I installed an older version of SQL Developer ( and was able to reset the DB connection. It's working just fine.
                        I think the new version ( wasn't running because the software automatically kept the same settings I had.
                        When I installed the older version I was asked if I wanted to migrate the current settings. I declined that and set the
                        connection to the DB manually. That made the trick. What is still unclear to me is why the version I had before (
                        stopped running in the first place.
                        • 9. Re: ORA-17008 error message
                          If you suspect you have corrupt settings, backup/delete the SQL Developer/systemXXX directory in the hidden Application Data under your Windows profile to reset your installation to defaults.

                          Hope that helps,