Impossible to start a listener: Failed to start service, error 3 TNS-12560

705249
    Hi all,

    I had a database in my machine in 10g.
    I have installed oracle 11.1.0.7 on the same machine.

    So now i have 2 oracle_home.
    With 10g I have a default listener which is running on port 1521.
    I wanted to run an other listener under the 11g oracle home.

    listener.ora:
    # listener.ora Network Configuration File: C:\ora111\network\admin\listener.ora
    # Generated by Oracle configuration tools.
     
    LISTENER2 =
      (DESCRIPTION_LIST =
        (DESCRIPTION =
          (ADDRESS = (PROTOCOL = TCP)(HOST = T0009696.corp.gltrade.com)(PORT = 1522))
          (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
        )
      )
    C:\ora111\BIN>lsnrctl start listener2 
    
    LSNRCTL for 32-bit Windows: Version 11.1.0.7.0 - Production on 16-MARS -2010 15:21:19 
    
    Copyright (c) 1991, 2008, Oracle.  All rights reserved. 
    
    Lancement de tnslsnr: Veuillez patienter... 
    
    Failed to start service, error 3.
    
    TNS-12560: TNS : erreur d'adaptateur de protocole
    
     TNS-00530: Erreur d'adaptateur de protocole
    Even if I stop the 10g listener I can't start the 11g listener. I also tried to start a default listener with 11g (name=listener and port=1521) but I get the same error.

    Please, can someone explain me the reason of such error ?
      1 2 3 上一个 下一个