7 Replies Latest reply on Apr 15, 2011 4:31 PM by user12019587

    how to initialize Forms Listener servlet

    Asmirnov-Oracle
      Hi,

      I installed the Forms Services 11g, right after that I could run the

      http://<host>:<port>/forms/frmservlet?form=test.fmx

      Then I shoutdown all, then restarted - opmnctl startall and I started both admin and managed weblogic servers.
      The problem is that I can not run

      http://<host>:<port>/forms/frmservlet?form=test.fmx - the page (IE) just going for ever.

      In the log file for when I did the install I can see this messages
      'Initializing Listener Servlet' and 'Initializing the forms servlet'
      but
      I don't see the message 'Initializing Listener Servlet' when I was staring all myself, only 'Initializing the forms servlet'.


      So my guess is I need to initialize Listener servlet, but I don't know how. Can anybody help?

      Thank you
      Anatoliy
        • 1. Re: how to initialize Forms Listener servlet
          Asmirnov-Oracle
          And to add to that - in the WLS_FORMS managed server I see this ERROR:

          [2010-03-16T16:08:11.676-04:00] [WLS_FORMS] [ERROR] [FRM-91230] [oracle.forms.servlet] [tid: 11] [userId: <anonymous>] [ecid: 0000ITc_nAS1vXgLlEL6iZ1Bbsb3000001,0] [SRC_CLASS: oracle.forms.servlet.RunformProcess] [APP: formsapp#11.1.1] [SRC_METHOD: fromFrmwebToODL] fatal error in runtime process: timeout on connection to Java client

          Any idea?
          • 2. Re: how to initialize Forms Listener servlet
            Michael Ferrante-Oracle
            There may be a port conflict. Try the following:

            1. Stop all of the Oracle processes. This includes all OPMN mananged procs and WLS. Verify that they are stopped using the Task Manager (if Windows) or the "ps" command if Unix. If any are not stopped, kill them manually.

            2. Start just the WLS_FORM managed server. Allow it at least one minute to initialize. The window starting the process will show the word "RUNNING" once it has successfully started.

            3. Open a browser and attempt to access the following:

            http://<host>:9001/forms/frmservlet/admin

            4. If the above works and displays "*Oracle Fusion Middleware 11g ...* "then try this:

            http://<host>:9001/forms/frmservlet?form=test

            If this works, there is likely a port conflict or a resource issue on the machine.
            • 3. Re: how to initialize Forms Listener servlet
              Asmirnov-Oracle
              Michael.

              It looks like you were right - it should be a port mis-match, I tried instead 8090 port - 9001 and it worked.
              One thing I am confused about - why did it reassign the port?
              When I finished the insatll yestreday it gave a list of ports assigned this is how I came at 8090 for the forms servlet.
              So why would it start now at 9001 I wonder? I guess it there would be a port conflict with the existing pports used it wouldn't even configure it during the install!
              But anyway - what matters that it is running happily now on 9001.
              By the way - I am new to this - to you know the location of the ervlet listener config file by any chance? (sorry)

              Thanks and Regards,

              Anatoliy
              • 4. Re: how to initialize Forms Listener servlet
                Michael Ferrante-Oracle
                Anatoliy,

                Please don't misunderstand what I was trying to do. Port 9001 is the port used by WLS_FORM. By accessing Forms using this port you are bypassing HTTP Server. The fact that this started when OPMN managed processes was not running indicates either a conflict or resource issue, which I assumed. Now that we know WLS_FORMS is starting and responding, you should try to start OPMN. Once OPMN appears to have started, try the same URLs again only this time use the Listen port for the HTTP Server. Unless the default ports were in use when the installation occurred, they will likely be as follows:

                Web Cache: 8090
                HTTP Server: 8888
                WLS_FORMS: 9001

                You should be able to access Forms from any of these ports, however at production time, you should use the HTTP Server for accessing Forms.

                Important thing to consider, if you are using this installation on a standalone machine (or even a server), you will need at least 3gig of RAM installed. Anything less will greatly decrease performance. By "performance" I don't necessarily mean the time it takes to get responses from the server or how fast a form appears to run. The performance I am concerned with is that which includes the starting of a process. If there sufficient RAM installed, starting processes will be delayed. This often results in a timeout and the attempt to start with fail.

                Regarding the Forms Servlet configuration file, I don't know specifically which file you are after or why you would want it, but all supported configuration changes can be made via EM or WLS Control.
                • 5. Re: how to initialize Forms Listener servlet
                  Asmirnov-Oracle
                  Thanks much for clarification, Michael.

                  Regards

                  A
                  • 6. Re: how to initialize Forms Listener servlet
                    Chris999
                    I too am getting FRM-91230 randomly on my production Forms Server (11.1.1.2).

                    When I open forms by :
                    http://win2003std32-3.ircsinc.local:8090/forms/frmservlet?form=mmhs.fmx
                    or
                    http://win2003std32-3.ircsinc.local:8888/forms/frmservlet?form=mmhs.fmx
                    both works by automatically flipping to:
                    http://win2003std32-3.ircsinc.local:8090/forms/frmservlet?form=mmhs.fmx
                    use of 9001 does not work at all.

                    I'm pretty frustrated troubleshooting these FRM-91230 errors which I believe each corresponds to a "hung" application on the users side.

                    I do not know whether it is a network issue or not, our form/reports 6i client/server application works very well in the same environment, so I hesitate to point towards the network.

                    Thanks,

                    Chris
                    • 7. Re: how to initialize Forms Listener servlet
                      user12019587
                      Hello everybody,

                      We are getting FRM-91230 error very often in log files as well in our production environment. It would be appreciated if anybody can say what could be a workaround to debug this error.