14 Replies Latest reply: Mar 12, 2013 8:27 AM by user7698698 RSS

    Killed Process Details

    611900
      Hello,

      Yesterday I got message in my alert log regading one of the killed process. Like -

      Thu Mar 18 23:10:31 2010
      Process 0x0x50000076290b220 appears to be hung in Auto SQL Tuning task
      Current time = <>, process death time = <>
      Attempting to kill process 0x0x50000076290b220 with OS pid = <>
      OSD kill succeeded for process 0x0x50000076290b220


      Since there is no trace file for this, how can I find more details about a killed process? (Here - 0x0x50000076290b220)

      Thanks!
        • 1. Re: Killed Process Details
          USER101
          By the looks of it, it looks like a memory address. I don't think you can track it down using any views.
          • 2. Re: Killed Process Details
            739162
            i got the same error.
            But the Oracle Enterprise Manager assign it to a critical error :( ....
            Maybe i guess this level is to high ...

            But is this a issue with scheduler or with the tuning task ?
            Is it critical or ignorable ?

            I'm shure: it is not critical if the "Auto SQL Tuning task" are not running for some days.
            In this case i will ignore this error, or can i fix it to avoid the next "critical alerts" reported by OEM ?

            DB Release: 11.1.0.7.2

            Edited by: user4441079 on 23.04.2010 02:04
            • 3. Re: Killed Process Details
              768973
              I am having the same/similar issue "Process XXX appears to be hung in Auto SQL Tuning task"

              Happens pretty much every day, sometimes more than once a day.
              • 4. Re: Killed Process Details
                768980
                I got the same error:

                <msg time='2010-04-25T15:19:01.679+02:00' org_id='oracle' comp_id='rdbms'
                msg_id='kesaiKillProcess:2487:3170456095' client_id='' type='ERROR'
                group='SQL_Tune' level='2' host_id='oracle2'
                host_addr='192.168.6.101' module='' pid='3521'>
                <txt>Process 0x0x10e4ddf20 appears to be hung in Auto SQL Tuning task
                </txt>
                </msg>
                • 5. Re: Killed Process Details
                  63881
                  Hello All,

                  I got the same error from grid console. Any help will be appreciated. Is it also possible to degrade this alarm level from critical to ignorable?

                  BR,
                  Derya.
                  • 6. Re: Killed Process Details
                    Pavan DBA
                    i would suggest you to raise an SR with oracle, if you can't found solution from google or metalink (may be it can be a bug)
                    • 7. Re: Killed Process Details
                      Billy~Verreynne
                      Seems like the Oracle base bug is 6214584. It's not public.

                      Other bug reports refers to it. It seems that the MMON process is responsible for killing the auto-tuning process that is considered to have exceed a specific time limit.

                      You'll need to file your problem with Oracle Support. I did not see a work-around being provided - except for possibly disabling auto tuning? Which sounds like a bad hack and not a work-around.
                      • 8. Re: Killed Process Details
                        63881
                        Hello,

                        I had opened an SR and the result is: It is a bug.
                        Bug 8636312: HUNG IN AUTO SQL TUNING TASK which is based on the Oracle base bug Billy gave above.
                        No workaround is provided, and the bug is not patched or solved in newer version.
                        Acknowledging this alert from the GC, solved my need of stopping the anoyingly coming of this alert.
                        You can acknowledge the alert by clicking the alert link, which brings details of it, containing "acknowlege" button.

                        This alert is related with the Metric: "Generic Operational Error"

                        Sincerely,
                        Derya.
                        • 9. Re: Killed Process Details
                          63881
                          The error came again, acknowledging does not solve.
                          • 10. Re: Killed Process Details
                            63881
                            Hello,
                            You can find how to drop auto tune sql tuning job here:
                            http://deryaoktay.wordpress.com/2010/05/11/hung-in-auto-sql-tuning-task-critical-alert-in-gc/
                            BR,
                            Derya
                            • 11. Re: Killed Process Details
                              783412
                              Hi Derya
                              I have the similar error reported by OEM as Critical for 5-6 times in last 2-days.
                              The ONLY thing available in alert log is :
                              Mon Jul 05 23:10:17 2010
                              Process 0x0x412016e50 appears to be hung in Auto SQL Tuning task
                              Current time = 1278389416, process death time = 1278389403
                              Attempting to kill process 0x0x412016e50 with OS pid = 7512
                              OSD kill succeeded for process 0x412016e50

                              xml log file has the following:
                              <msg time='2010-07-05T23:10:17.512-05:00' org_id='oracle' comp_id='rdbms'
                              msg_id='kesaiKillProcess:2474:1670650406' client_id='' type='ERROR'
                              group='SQL_Tune' level='2' module=''
                              pid='15013'>
                              <txt>Current time = 1278389416, process death time = 1278389403

                              The Bug 8636312, is this for 11g?

                              Any work around suggested by the SR!

                              Thanks
                              Kulvinder
                              • 12. Re: Killed Process Details
                                snmdla
                                I have the same problem. Oracle support has been working (waiting?) on this since May-2009, without real progress.

                                The Auto SQL Tuning task is deamed to be hung about thrice a week, and from time to time, even PMON is shot down, causing the instance to crash immediately:

                                Tue Mar 13 23:10:18 2012
                                Process 0x0x26002b078 appears to be hung in Auto SQL Tuning task
                                Current time = 1331676618, process death time = 1331676605
                                Attempting to kill process 0x0x26002b078 with OS pid = 26466
                                OSD kill succeeded for process 0x26002b078
                                Tue Mar 13 23:10:39 2012
                                Errors in file /u01/app/oracle/diag/rdbms/orainst/orainst/trace/orainst_m000_15963.trc:
                                ORA-00472: PMON process terminated with error
                                Tue Mar 13 23:10:39 2012
                                DBW1 (ospid: 24155): terminating the instance due to error 472
                                Tue Mar 13 23:10:39 2012
                                ORA-1092 : opiodr aborting process unknown ospid (27738_47437538569824)
                                Tue Mar 13 23:10:39 2012
                                ORA-1092 : opitsk aborting process
                                Instance terminated by DBW1, pid = 24155

                                This is a very annoying issue. Has anybody been able to solve this on his own?

                                Regards, Tom

                                Edited by: snmdla on Mar 14, 2012 8:14 AM
                                • 13. Re: Killed Process Details
                                  snmdla
                                  this issue got finally solved through updating to 11.2.0.3.

                                  Regards, Tom
                                  • 14. Re: Killed Process Details
                                    user7698698
                                    False.