4 Replies Latest reply: Mar 16, 2011 2:35 AM by 634791 RSS

    Integrated WLS only works when SSL is enabled

    412740
      Hi,

      I'm using JDeveloper 11g on a WinXP machine. It's a clean install with a user account where I deleted the data folder +%USERPROFILE%\Application Data\JDeveloper+. I use the "Create Default Domain" option from the "Application Server Navigator" view to initialize a domain for 127.0.0.1.

      My problem is that when the server is running (Run->Start Server Instance....) I cannot connect to the server from JDeveloper. Right-clicking on the server entry and going to the "Test" tab of its properties, I choose "Test connection" and get:
      Testing JSR-160 Runtime                ... failed.
      Cannot establish connection.
      Testing JSR-160 DomainRuntime          ... skipped.
      Testing JSR-88                         ... skipped.
      Testing JSR-88-LOCAL                   ... skipped.
      Testing JNDI                           ... skipped.
      Testing JSR-160 Edit                   ... skipped.
      Testing HTTP                           ... success.
      Testing Server MBeans Model            ... skipped.
      
      1 of 8 tests successful.
      However, if I enable SSL by editing "config.xml" from +%USERPROFILE%\Application Data\JDeveloper\system11.1.1.2.36.55.36\DefaultDomain\config+ by adding:
            <ssl>
            <name>DefaultServer</name>
            <enabled>true</enabled>
             <listen-port>7102</listen-port>
          </ssl>
      Somehow this results in everything working:
      Testing JSR-160 Runtime                ... success.
      Testing JSR-160 DomainRuntime          ... success.
      Testing JSR-88                         ... success.
      Testing JSR-88-LOCAL                   ... success.
      Testing JNDI                           ... success.
      Testing JSR-160 Edit                   ... success.
      Testing HTTP                           ... success.
      Testing Server MBeans Model            ... success.
      
      8 of 8 tests successful.
      What could be causing this behavior?
        • 1. Re: Integrated WLS only works when SSL is enabled
          Pedja
          Hi,

          When you right-click the server in the Application Server Navigator and go to properties, check on the Configuration tab if 'Always use SSL' is checked. If yes, try without it.

          Pedja
          • 2. Re: Integrated WLS only works when SSL is enabled
            412740
            I'm using the UI settings properly. I checked "Always use SSL" when I enabled SSL and unchecked it prior to that. However, JDeveloper should work whether SSL is available or not: i.e. when "Always use SSL" is unchecked, it should work anyway. It doesn't. The only way to get it to work is to check "Alway use SSL" (and of course enable the SSL port in config.xml).
            • 3. Re: Integrated WLS only works when SSL is enabled
              412740
              I'm still having this problem, but have found that according to the documentation, the administration port does in fact require SSL:

              http://download.oracle.com/docs/cd/E15523_01/web.1111/e13701/network.htm#i1059057


              Does really nobody have a clue?
              • 4. Re: Integrated WLS only works when SSL is enabled
                634791
                By default when you install SOA ,the SSL ports are enabled.
                You can check the same in your weblogic admin console.
                Go to general page and you can see there ssl port is selected or not.
                If you have SSL enabled in weblogic console,by default when ever you will try to deploy your process to server it will take https.
                Just try to disable the ssl port from weblogic console and now try to deploy you will find the server address as http

                Now coming back to your problem "using ssl"

                If you want to use SSL to deploy your process in a server then you need to import the certificate of the server(the server which is SSL enabled and where you want
                to deploy your process) then you need to import the certificate in to the keystore of Jdveloper.

                Jdeveloper KeyStore can be found in <JDEV_HOME>\jdk\jre\lib\security\cacerts


                Using following command import the certificate you saved from firefox:
                i.e: keytool -import -v -trustcacerts -alias servercert -file certificate.crt -keystore $JDEV_HOME/jdk/jre/lib/security/cacerts -storepass changeit


                Now restart your jdeveloper and try to deploy