This discussion is archived
4 Replies Latest reply: Apr 8, 2010 12:47 AM by RenévanWijk RSS

WLDF error when trying to start Managed Server

719194 Newbie
Currently Being Moderated
Hi,

I'm receiving the following error when I try to start my Managed Server. I'm using weblogic 10.3.1 and it was working fine last week. Today, I tried to retsart the server and hasn't worked since. What is WDLF and what is it's function? I have a number of these stack dumps in my log as it tries to start each application.

Can anyone help?

####<Apr 6, 2010 2:40:22 PM EDT> <Error> <Deployer> <inodcwaa04> <GeoMS1> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1270579222754> <BEA-149231> <Unable to set the activation state to true for the application 'iSmartWebEditor'.
java.lang.IllegalStateException: WLDF Module not in PREPARED state during activate() callback. State was 0
     at weblogic.diagnostics.module.WLDFModule.activate(WLDFModule.java:281)
     at weblogic.application.internal.flow.DeploymentCallbackFlow$2.next(DeploymentCallbackFlow.java:415)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:83)
     at weblogic.application.internal.flow.DeploymentCallbackFlow.activate(DeploymentCallbackFlow.java:75)
     at weblogic.application.internal.flow.DeploymentCallbackFlow.activate(DeploymentCallbackFlow.java:67)
     at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:1267)
     at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:83)
     at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:409)
     at weblogic.application.internal.EarDeployment.activate(EarDeployment.java:54)
     at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:161)
     at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:79)
     at weblogic.deploy.internal.targetserver.BasicDeployment.activate(BasicDeployment.java:184)
     at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:361)
     at weblogic.management.deploy.internal.DeploymentAdapter$1.doActivate(DeploymentAdapter.java:51)
     at weblogic.management.deploy.internal.DeploymentAdapter.activate(DeploymentAdapter.java:196)
     at weblogic.management.deploy.internal.AppTransition$2.transitionApp(AppTransition.java:30)
     at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:233)
     at weblogic.management.deploy.internal.ConfiguredDeployments.activate(ConfiguredDeployments.java:169)
     at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:123)
     at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:173)
     at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:89)
     at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
     at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
     at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
  • 1. Re: WLDF error when trying to start Managed Server
    RenévanWijk Oracle ACE
    Currently Being Moderated
    What WLDF is can be found here: http://download.oracle.com/docs/cd/E12529_01/wlss31/operations/wldf.html

    Seeing your error log, i think there is something wrong with the application (EAR). Have you changed the EAR since you last deployed it. Or have you after having stopped your server, put an other EAR it's place.

    Maybe this is not very helpful - i know, but the above is something i ran into as well.
  • 2. Re: WLDF error when trying to start Managed Server
    719194 Newbie
    Currently Being Moderated
    Thank you, Rene!

    I will try redeploying the application and post the results. I might have removed and EAR file while cleaning up residual files and may have mistakenly removed one that was needed!
  • 3. Re: WLDF error when trying to start Managed Server
    719194 Newbie
    Currently Being Moderated
    Hi Rene,

    I re-deployed the application ensuring the proper EAR files were in place, but no luck. I get the same error. Each of the application seem to be unable to be activated because WLDF module is not in a prepared state.

    java.lang.IllegalStateException: WLDF Module not in PREPARED state during activate() callback. State was 0


    Amy I missing something?
  • 4. Re: WLDF error when trying to start Managed Server
    RenévanWijk Oracle ACE
    Currently Being Moderated
    Maybe there is something wrong with some of the logging services of the managed servers. These logging services also belong to WLDF. Did you change some directory (Enviroment-->Servers-->YouServer-->Logging) for the servers to log to. Do these directories exist? Or does the application use the logging services in some way?

    From your first post, i do not think you have any WLDF modules configured, which are for example used for instrumentation?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points