1 Reply Latest reply: Apr 15, 2010 12:52 AM by 766816 RSS

    essbase + 1051223

    766816
      hi
      after having changed the shared services root password (why? because i'm stupid!) I'have these error on essbase:
      [Thu Apr 15 06:50:03 2010]Local/ESSBASE0///Info(1051283)
      Retrieving License Information Please Wait...
      [Thu Apr 15 06:50:03 2010]Local/ESSBASE0///Info(1051286)
      License information retrieved.
      *[Thu Apr 15 06:50:35 2010]Local/ESSBASE0///Error(1051223)*
      *Single Sign On function call [css_init] failed with error [CSS Error: CSS method invocation error: com.hyperion.css.CSSSystem.<init>]*
      *[Thu Apr 15 06:50:35 2010]Local/ESSBASE0///Info(1051198)*
      Single Sign-On Initialization Failed !
      [Thu Apr 15 06:50:35 2010]Local/ESSBASE0///Info(1051232)
      Using English_UnitedStates.Latin1@Binary as the Essbase Locale

      if I chek the shared services security client log, I find this error:

      2010-04-15 06:50:32,564 WARN [main] Attempting to connect to Native Directory: Retry Count: 9 com.hyperion.css.spi.CSSManager.getProviderInstance(Unknown Source)
      2010-04-15 06:50:32,564 ERROR [main] 27:1062:*Failed to connect to the user directory Native Directory.[Root Cause: [LDAP: error code 49 - Invalid Credentials] ]* com.hyperion.css.spi.util.jndi.pool.JNDIConnectionPool.init(Unknown Source)
      2010-04-15 06:50:32,564 ERROR [main] 27:1062:Failed to connect to the user directory Native Directory.[Root Cause: [LDAP: error code 49 - Invalid Credentials] ] com.hyperion.css.spi.util.jndi.pool.JNDIConnectionPool.init(Unknown Source)
      2010-04-15 06:50:32,564 WARN [main] Failed to instantiate provider for factory: com.hyperion.css.spi.impl.nv.NativeFactory.[Root Cause: 27:1062:Failed to connect to the user directory Native Directory. ] com.hyperion.css.spi.CSSManager.getProvider(Unknown Source)
      2010-04-15 06:50:32,564 WARN [main] Native Directory is not reachable. Will try to re-connect after 3 seconds... com.hyperion.css.spi.CSSManager.getProviderInstance(Unknown Source)
      2010-04-15 06:50:35,576 WARN [main] Attempting to connect to Native Directory: Retry Count: 10 com.hyperion.css.spi.CSSManager.getProviderInstance(Unknown Source)
      2010-04-15 06:50:35,576 ERROR [main] 20:3008:Failed to connect to native directory. com.hyperion.css.spi.CSSManager.getProviderInstance(Unknown Source)
      2010-04-15 06:50:35,576 ERROR [main] Arguments: param1={}, param2=null, param3=C:\Hyperion\logs\essbase\, com.hyperion.css.CSSSystem.initCSSSystem(Unknown Source)

      anybody could help me to explain to essbase the new root password?
      many thanks for your patience and your time
      lavez
        • 1. Re: essbase + 1051223
          766816
          moreover, I've added
          SharedServicesLocation NVM01 28080
          AuthenticationModule CSS http://nvm01:28080/interop/framework/getCSSConfigFile

          I can see that the css file "getted" is this one:

          <?xml version="1.0" encoding="UTF-8" ?>
          - <!-- Sample XML file generated by XML Spy v4.4 U (http://www.xmlspy.com)
          -->
          - <css>
          - <hub location="http://nvm01:28080">
          <dirPort>28089</dirPort>
          </hub>
          - <spi>
          - <provider>
          - <native name="Native Directory">
          <password>{CSS}Gvhy1I2E/N6Wle4zRiiTyA==</password>
          <authenticationModuleEnabled>false</authenticationModuleEnabled>
          <vendor>OPENLDAP</vendor>
          <url>ldap://nvm01:28089</url>
          <userDN>cn=root,dc=css,dc=hyperion,dc=com</userDN>
          </native>
          </provider>
          </spi>
          - <searchOrder>
          <el>Native Directory</el>
          </searchOrder>
          - <token>
          <timeout>480</timeout>
          </token>
          - <logger>
          <priority>WARN</priority>
          </logger>
          - <delegatedUserManagement>
          <enabled>false</enabled>
          </delegatedUserManagement>
          </css>

          I suppose the problem is <password>{CSS}Gvhy1I2E/N6Wle4zRiiTyA==</password> ....but how to regenerate?
          I think that probably this is based on C:\Hyperion\deployments\Tomcat5\SharedServices9\config\CSS.xml...correct?
          this one:
          <?xml version="1.0" encoding="UTF-8" ?>
          - <!-- Sample XML file generated by XML Spy v4.4 U (http://www.xmlspy.com)
          -->
          - <css>
          - <hub location="http://nvm01:28080">
          <dirPort>28089</dirPort>
          </hub>
          - <spi>
          - <provider>
          <native name="Native Directory" />
          </provider>
          </spi>
          - <searchOrder>
          <el>Native Directory</el>
          </searchOrder>
          - <token>
          <timeout>480</timeout>
          </token>
          - <logger>
          <priority>WARN</priority>
          </logger>
          - <delegatedUserManagement>
          <enabled>false</enabled>
          </delegatedUserManagement>
          </css>

          similar but not the same....the difference are generated in the deplyment phase?
          help!
          lavez