3 Replies Latest reply: Apr 20, 2010 5:30 PM by 696497 RSS

    LIBSCA_CAT:306: ERROR. SALT 11gR1.


      I tried to run the simp_python SCA example, and I get this error:

      153915.680.TE802179!SCAHOST.4204.5676.0: LIBSCA_CAT:306: ERROR: Failed to initialize SCA runtime: Exception
      Class: SystemConfigurationException
      Description: Implementation type not supported: http://www.osoa.org/xmlns/sca/1.0#PythonImplementation
      File: ModelLoader.cpp
      Line: 404
      Function: tuscany::sca::model::ModelLoader::addComponent
      153915.696.TE802179!SCAHOST.4204.5676.0: LIBTUX_CAT:250: ERROR: tpsvrinit() failed
      153915.696.TE802179!tmboot.2504.5844.-2: 04-20-2010: Tuxedo Version, 32-bit
      153915.696.TE802179!tmboot.2504.5844.-2: CMDTUX_CAT:825: ERROR: Process SCAHOST at simple failed with /T tperrno (TPENOENT - no entry found)

      What is the problem?

      Thanks in advance.
        • 1. Re: LIBSCA_CAT:306: ERROR. SALT 11gR1.

          More information about this problem.
          I tried to import sca module in python, and I get this:

          Python 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)] on win32
          Type "help", "copyright", "credits" or "license" for more information.
          import sca
          Traceback (most recent call last):
          File "<stdin>", line 1, in <module>
          ImportError: DLL load failed: The specified module could not be found.

          All the enviroment variables are set, including the PYTHONPATH.

          Any ideas?

          Thanks in advance

          PS: Platform: Windows 2003 Server x86.
          • 2. Re: LIBSCA_CAT:306: ERROR. SALT 11gR1.
            Todd Little-Oracle
            Hi Cristian,

            I believe the problem is likely the version of Python you are using. The documentation appears to be missing a crucial piece of information and that is that you must be using Python version 2.5.4. Try that and see if it fixes your problem.

            Todd Little
            Oracle Tuxedo Chief Architect
            • 3. Re: LIBSCA_CAT:306: ERROR. SALT 11gR1.

              Thanks for the reply. That fixed it. Python 2.5.4 IS the version to use.