5 Replies Latest reply on Jun 10, 2010 10:23 AM by 778471

    OPatch error when installing Patch #5059238

    772085
      System Info: Windows 7 64-bit
      DB/Client version: Oracle 10g - 32 bit version

      Background: everything works fine with this Oracle installation except when I try to connect to Oracle DB using ADODB connection string I get "Cannot Open Connection" error. Apparently this is due to the fact that the application from which I run the ADODB command is under "C:\Program Files (x86)" and due to the parentheses the error occurs . After some research, I found that patch #5059238 resolves this issue and so I downloaded it and tried to install it using the OPatch utility.

      ORACLE_HOME: C:\Oracle\product\10.2.0\client_1

      JAVA_HOME: C:\Program Files (x86)\Java\jre6

      Path: ;C:\oracle\product\10.2.0\client_1;C:\Program Files (x86)\Java\jre6;C:\oracle\product\10.2.0\client_1\OPatch\jlib\opatch.jar;C:\oracle\product\10.2.0\client_1\OPatch\jlib\opatchprereq.jar;C:\oracle\product\10.2.0\client_1\OPatch\jlib\opatchutil.jar;C:\oracle\product\10.2.0\client_1\OPatch

      Now on running the "opatch apply" or "opatch lsinventory" from C:\5059238 I get the following error :

      Invoking OPatch 10.2.0.1.0

      Oracle interim Patch Installer version 10.2.0.1.0
      Copyright (c) 2005, Oracle Corporation. All rights reserved..

      java.lang.NullPointerException
      at oracle.sysman.oii.oiix.OiixPathOps.concatPath(OiixPathOps.java:553)
      at oracle.opatch.OPatch.setupEnvironment(OPatch.java:227)
      at oracle.opatch.OPatch.main(OPatch.java:502)

      OPatch failed with error code = 255

      Please let me know if anyone has any idea what's going on here and if you have any solutions.

      Thanks in advance!!

      -Pratik Nagar