1 Reply Latest reply: Jun 14, 2010 11:30 AM by john dickey, mccarthy RSS

    Server Package Build Timeouts during DLL transfer

    WBF_dba
      Hello,

      We are experiencing an issue building full production packages for our PD812 environment on our iseries (syste i/570). The server build eventually times-out during the DLL transfer to the iseries, and then proceeds to build fine on our 2 Windows 2003 batch servers, and the timeout occurs randomly on any of the DLLs. For example, during the build attempt below, the timeout occurred during the CWIM dll transfer to the iseries. During a previous attempt, the build timed-out during the CSALES transfer.

      I haven't located any AS400 job logs that were helpful, but I located the kernel error shown below.

      I have tried a couple of different build machines.

      Thanks

      Section of ServerPkgBuild.log
      Fri May 28 19:01:07 - Transferring business functions for DLL CTOOL to server.

      Fri May 28 19:01:09 - Transferring business functions for DLL CTRAN to server.

      Fri May 28 19:01:31 - Transferring business functions for DLL CTRANS to server.

      Fri May 28 19:01:36 - Transferring business functions for DLL CWARE to server.

      Fri May 28 19:02:02 - Transferring business functions for DLL CWIM to server.

      Sun May 30 01:02:37 - spkgclnt.c:742 PKGCLT0032 ERROR: Failed to receive message. Error Timeout.

      Sun May 30 01:02:38 - spkgclnt.c:1471 PKGCLT0054 ERROR: Failed to transfer \\WBF-DEPLOY1\E812\PD812\package\PD812FL\source\b31b7309.c to the server.

      Sun May 30 01:02:38 - spkgclnt.c:633 PKGCLT0024 ERROR: JDENET_CreateAssocMsg failed. Error Connection closed.

      JDENET_N Kernel Log:

      300/2 MAIN_THREAD Thu Jun 10 11:29:45.808216 netrcv.c1069
      Error on call to fopen with file /OneWorld/Packages/PD812FN/include/b90ca302.h, errno-3474, cannot save file packet for msg 22320

      The full build process worked fine in March, and nothing has changed on the iseries, the build machines, or within our network infrastructure that we are aware of.

      The build fails during the initial build attempt from the Package Build app (P9621), and it fails after a resubmit from the Package Build app (P9621 Advanced/reset), but it succeeds after resbmitting from Package Build History (P9622), but can I trust the package?


      Jd Edwards 8.12 TR 8.96 G1
      System i/570 iseries, V5R4 (Enterprise Server)
      Deployment Server Windows - 2003 Server
      Build Machine Windows - 2003 Server

      Thanks

      --------------------
      Mark S. Gollehon
      Sr CNC/DBA
      Wm Bolthouse Farms, Inc.
      Bakersfield, Ca USA
      AS400 (i830, i520, i570), JAS (Websphere 4.0 and Oracle App Server), EnterpriseOne Xe, 8.0, and 8.12.
      Createform
      Kronos
      iTera
      Tl Ashford Barcode 400
        • 1. Re: Server Package Build Timeouts during DLL transfer
          john dickey, mccarthy
          Mark,
          Ah, you have my deepest sympathy, having to work with One World/Enterprise One. So much more complicated than JDE World is. Unfortunately, you have posted this in the JDE World forum. There is actually a separate forum for JDE Enterprise One. To navigate there, go back to the Forum Home. Scroll down past the JDE World forum and you will find a forum for JDE Enterprise One. That is where you will want to post this item. While JDE World runs on the AS/400 (and only on the AS/400 - no windows servers), we don't have to deal with package builds and stuff like that. JDE World, if you are not aware, is technically much different from the Enterprise One software. So you are not likely to find much help in the JDE World forum. By the way, you are far from the first Enterpise One person to post an item in JDE World. I guess folks see "JDE" and think they are in the right place. Good luck.

          John Dickey