2 Replies Latest reply: Jun 20, 2010 10:21 PM by user12158503 RSS

    DBMS_NETWORK_ACL_ADMIN.CHECK_PRIVILEGE' must be declared after 11g upgrade

    user12158503
      Hi,
      I just uograded my dev database to from 10.2.0.4 to 11.1.0.7.2. During the testing phase of the upgrade, I had come up wiht scripts to execute after the upgrade to 11g so that my utl_smtp packages will run. But now, after upgrading to 11g, when I run these scripts, I get the below error -

      ORA-06550: line 4, column 33:
      PL/SQL: ORA-00942: table or view does not exist
      ORA-06550: line 4, column 3:
      PL/SQL: SQL Statement ignored
      ORA-06550: line 6, column 4:
      PLS-00201: identifier 'DBMS_NETWORK_ACL_ADMIN.CHECK_PRIVILEGE' must be declared

      During the testing phase, I installed 11g instance and created an 11g database and then imported the 10g objects into the 11g database so as to test the application. Now, I think what happened is when I upgraded my 10g database to 11g using DBUA, it did not install APEX. I ytried to configure APEX by following instructions from this site - http://www.oracle.com/technology/obe/11gr1_db/install/apexinst/apexinst.htm and this gives me error the error -


      PLS-00201: identifier 'DBMS_XDB.SETHTTPPORT' must be declared


      How do I install apex?Can someone please guide me this?

      Thanks
        • 1. Re: DBMS_NETWORK_ACL_ADMIN.CHECK_PRIVILEGE' must be declared after 11g upgrade
          618702
          Hi user12158503,

          Can you please post the output of v$registry_history?

          Have you executed the utlrp.sql script after the upgrade?

          If you followed the documented steps and you have got that error at the end, please create an SR call if you have access to the metalink.

          Ogan
          • 2. Re: DBMS_NETWORK_ACL_ADMIN.CHECK_PRIVILEGE' must be declared after 11g upgrade
            user12158503
            Hi, Ogan, I got this resolved.
            After the upgrade by using DBUA, I tried to execute scripts to configure ACLs since my database has dependent objects. That's when I got error saying that dbms_network_acl_admin was not found.

            when I queried DBA_registry , it didn't list XDB as one of the components. So, I understood this didn't get installed during the upgrade with DBUA. So, I installed XDB manually by running catqm.sql. This however created a lot of invalid objetcs which wouldnt get validated after tryign to recompile them with utlrp.sql. Most of the errors were looping chain of synonyms. Finally, I de-installed it and re-installed xdb and ran utlrp.sql to validate all the invalid objects. Now, everything is fine.

            I guess xdb doesn't get installed during the dbua upgrade and maybe it needs to be installed seperately. But, that's kind of confusing because xdb is supposed to be a mandatory component in 11g. Can someone please clarify this?