1 Reply Latest reply on Jun 28, 2010 1:17 PM by 715399

    Servlet marked unavailable

    778362
      Hi,

      I have a problem whereby whenever i run the servlet, my serlvlet was marked as unavailable. have Stripped down the servlet to bare minimum and was able to run it. It was only after i placed the following code that it was unable to run.

      +public void doGet (HttpServletRequest request, HttpServletResponse response, String additionalParameter) throws ServletException, IOException, Exception {+
      +     +
      +     int which = 0;+
      +     String name = request.getParameter( "name" );+

      +     try {+
      +          Oracle oracle = new Oracle(jdbcUrl, user, password);+
      +               +
      +               Attachment attachment = Attachment.createInstance(+
      +                         new String[] {}, "OWLPRIME",+
      +                         InferenceMaintenanceMode.NO_UPDATE, QueryOptions.DEFAULT);+

      +               +
      +               GraphOracleSem graph = new GraphOracleSem(oracle, modelName, attachment);+
      +               ModelOracleSem model3 = new ModelOracleSem(graph);+

      Part of the error is as follow:

      Jun 22, 2010 9:44:50 AM org.apache.catalina.core.ApplicationContext log
      INFO: Marking servlet ExpertFinderServlet as unavailable
      Jun 22, 2010 9:44:50 AM org.apache.catalina.core.StandardWrapperValve invoke
      SEVERE: Allocate exception for servlet MyServlet
      java.lang.ClassNotFoundException: com.hp.hpl.jena.rdf.model.Model
           at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1516)
           at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1361)

      Unable to find explaination or solution to this problem. Would appreciate any help here. Thank You.