3 Replies Latest reply: Jun 29, 2012 3:21 AM by Audun Nes RSS

    weblogic.management.ManagementException: Booting as admin server, but serve

    user4859495
      Weblogic 10.3.2, with Node Manager as a Windows Service running.

      Used the Configuration Wizard to create a domain with a Machine, Admin Server and 2 Managed Servers. Still in the wizard I added the AdminServer and 2 Managed Servers to the machine.

      Using a python script I connect to the Node Manager using a WLST command and try to start all servers (AdminServer, ManagedServer_A, ManagedServer_B). The AdminServer comes up but the Managed Servers fail to start. I tried running the 'nmEnrolll' command from WLST, that didnt help. The only way I have found around the problem is to log into the Admin Console and start the Managed Servers from the console..then they will come up via WLST. This is not an acceptable solution as the scripts will be running in an "Installer" for configuration and deployment for our our Weblogic domain. I assume it has something to do with boot.properties? or some 'security' feature but have searched the Weblogic documentation and forums with no luck.

      thx tom

      e.g. WLST command and try to start all servers (with correct values replaced for variables)
      nmConnect(wlsAdminUsername, wlsAdminPassword, NMListenAddr, NMListenPort, wlsDomainName, wlsDomainDir, NMType)
      nmStart('AdminServer')
      nmStart(ManagedServer_A)
      nmStart(ManagedServer_B)

      The log for each of the Managed Server states (excerpt from ManagedServer_B):

      <Jun 23, 2010 10:18:10 AM> <INFO> <NodeManager> <Server output log file is 'C:\Oracle\Middleware\user_projects\domains\mockup\servers\ManagedServer_B\logs\ManagedServer_B.out'>
      <Jun 23, 2010 10:18:11 AM MDT> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with BEA JRockit(R) Version R27.6.5-32_o-121899-1.6.0_14-20091001-2107-windows-ia32 from BEA Systems, Inc.>
      <Jun 23, 2010 10:18:12 AM MDT> <Info> <Management> <BEA-141107> <Version: WebLogic Server 10.3.2.0 Tue Oct 20 12:16:15 PDT 2009 1267925 >
      <Jun 23, 2010 10:18:13 AM MDT> <Info> <Security> <BEA-090065> <Getting boot identity from user.>
      Enter username to boot WebLogic server:Error: Failed to get value from Standard Input
      Enter password to boot WebLogic server:
      <Jun 23, 2010 10:18:13 AM MDT> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason:

      There are 1 nested errors:

      weblogic.management.ManagementException: Booting as admin server, but servername, ManagedServer_B, does not match the admin server name, AdminServer
           at weblogic.management.provider.internal.RuntimeAccessService.start(RuntimeAccessService.java:67)
           at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:461)
           at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:166)
           at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:749)
           at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:488)
           at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:446)
           at weblogic.Server.main(Server.java:67)

      >
      <Jun 23, 2010 10:18:13 AM MDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED>
      <Jun 23, 2010 10:18:13 AM MDT> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down>
      <Jun 23, 2010 10:18:13 AM MDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
        • 1. Re: weblogic.management.ManagementException: Booting as admin server, but serve
          user4859495
          more: After starting the AdminServer with the nmStart command I also tried connecting to the AdminServer and generating Boot Startup Properties for ManagedServer_B to see if this would help.

          Problem is the files are generated in the directory where I am invoking the script from, 'C:\mockserver\scripts'. Need to find out how to get the files to be generated in the domain directory: 'C:\Oracle\Middleware\user_projects\domains\mockup\servers\ManagedServer_B\data\nodemanager' as they are of no help in my scripts directory. For testing sake I tried moving the generated startup and boot properties to 'C:\Oracle\Middleware\user_projects\domains\mockup\servers\ManagedServer_B\data\nodemanager' and it made no difference..the ManagedServer_B still fails to start.

          WLST:
          connectToSvrEncrypted(nmUserConfigFileFinal, nmUserConfigKeyFileFinal, 't3s://localhost:7002')
          nmGenBootStartupProps('ManagedServer_B')
          disconnect()

          Command Window output:
          Successfully generated boot.properties at C:\mockserver\scripts\servers\ManagedServer_B\data\nodemanager\boot.properties.
          Successfully generated startup.properties at C:\mockserver\scripts\servers\ManagedServer_B\data\nodemanager\startup.properties.

          Edited by: user4859495 on Jun 23, 2010 10:41 AM

          Edited by: user4859495 on Jun 23, 2010 11:03 AM
          • 2. Re: weblogic.management.ManagementException: Booting as admin server, but serve
            user4859495
            After mucking around some more I found a way around it. Somewhere there must be a 'rule' that says the MangedServers must be started by a connection to the AdminServer, which can accomplished via WLST, before NodeManager can start/stop? Maybe there is Weblogic documentation on this somewhere?

            connectToSvrEncrypted(nmUserConfigFileFinal, nmUserConfigKeyFileFinal, 't3s://localhost:7002')
            start('ManagedServer_A', block='true')
            start('ManagedServer_B', block='true')

            From, there on out Node Manager can start/stop the Managed Server(s). Hope this of some help, assuming I went about it the right way.
            • 3. Re: weblogic.management.ManagementException: Booting as admin server, but serve
              Audun Nes
              A similar workaround worked for me:

              After starting up AdminServer through WLST to the Nodemanager, I started up the Managed Server through the WLS console. Then shut it down again through the WLS console.
              All subsequent attempt to start the managed server through WLST have been successful.