3 Replies Latest reply: Sep 14, 2010 9:18 AM by cruz878 RSS

    Primavera Project Planner 3.1 Installation on Windows 7

      I'm having trouble installing project planner 3.1 on windows 7 it says " the version of this file is not compatible with the version of windows you are running. check your computer systems information to see whether you need you need an X86 (32bit) or X64 (64bit) version of the program and then contact the software publisher"

      Please help.....thanks