6 Replies Latest reply: Jun 28, 2010 12:02 PM by jaramill RSS

    Oracle Forms 11g - ORA-12154: TNS error

    jaramill
      Okay, before I post my info, I searched and searched everywhere via Google, OTN, Experts-Exchange, etc...to try to figure this one out and I'm stumped. So here goes. I get the dreaded "*ORA-12154: TNS:could not resolve the connect identifier specified*" error. Here's my environment:

      ----------------------------------------------------------------------------------------------
      Server: Red Hat Enterprise Linux 5 version runs the following:
      Oracle Database 11g (Rel 1): 11.2.0.10
      Oracle Fusion Middleware Forms Server 11g (Rel. 11.1.1.2.0)

      I can connect via SQL+ no problem
      ----------------------------------------------------------------------------------------------
      Client: My Windows XP Professional PC.

      I can TNSPING the database SID no problem.
      I can connect via SQL+ no problem
      I can connect via TOAD to the db no problem
      I can connect to Oracle Enterprise Manager via the web interface no problem

      I do have 2 Oracle Homes (Oracle 8.0.6, Oracle 11.1.0.1) on my PC. Currently the current home is the 11g one. I do have my paths on my PC setup fine.

      The problem is when I try to run a sample form via the web I created, the login prompt comes up and I enter my username/password/database SID and that's when I get the error. Any clues as to what I should look for? Eventually this will be an app that all the users will be accessing and they shouldn't have to worry about having anything setup on their PCs.

      Thanks