2 Replies Latest reply on Jul 16, 2010 1:51 PM by Tommy.Reynolds-Oracle

    Package Binutils is not installed

    784847
      Hello Guru

      After downloading Redhat Linux 4 on VMware I run the following script to chk rpm

      rpm -q glibc glibc-common gcc gcc-c++ libstdc++ libstdc++-devel libaio \
      binutils make compat-db gnome-libs pdksh sysstat
      its show all rpm good but in binutils its sows that

      package binutils is not installed.

      After that i run the following script

      #rpm -qa|grep binutils

      Its show the binutils - 2.15.92.0.2-22

      so now what should i have to do to install package binutils

      thanks and regards

      victor hingu
        • 1. Re: Package Binutils is not installed
          506787
          my guess would be you've made a typo or inserted a non-printable character.
          could you try:
          rpm -q binutils
          • 2. Re: Package Binutils is not installed
            Tommy.Reynolds-Oracle
            First see if you really have binutils:
            # /usr/bin/which ld
            /usr/bin/ld
            # /bin/rpm -qf /usr/bin/ld
            binutils-....
            If either command returns an error, you do not have {font:Courier}binutils{font} installed.

            The package will be on your distribution media, so mount it and do something similar to:
            # cd /media/distro
            # find . -name binutils\* -print
            Server/.../binutils-<version>.rpm
            # rpm -Uvh Server/.../binutils-<version>.rpm
            If you downloaded Oracle Enterprise Linux, you can get the RPM from http://public-yum.oracle.com/repos/ if that is easier than finding your distribution media.