7 Replies Latest reply on Jul 23, 2010 11:07 PM by alwu-Oracle

    Joseki datasource configuration / statement caching

    766393
      Hi,

      I am using Joseki on a Weblogic 10.3.2 server (it is the only web app running on this server).
      I have been following the documentation to create the required data source (7.2.1) : http://download.oracle.com/docs/cd/E11882_01/appdev.112/e11828/sem_jena.htm#CBBBFDJC

      By default, Weblogic will set the following parameters regarding statement caching :
      - Statement Cache Type : LRU
      - Statement Cache Size : 10

      The problem is that statement caching is causing memory issues with Joseki. In my case, only a few queries caused the server to run out of free memory, and eventually to fail on new queries with OoM errors.

      Clearing the statement cache released the memory. Disabling it completely (by setting Statement Cache Size at 0) fixed the issue.

      So :
      Why does statement caching hold on so much memory when used with Joseki ?
      Is there a way to fix the OutOfMemory issue without disabling statement caching (prevent the cache from exhausting ALL available memory) ?
      Should the documentation advise users to disable statement caching if used with Joseki ?

      Regards,
      Julien