2 Replies Latest reply on Jul 26, 2010 12:58 AM by 751686

    error while  installing rpm elfutils-libelf-devel package

    751686
      while trying to install elfultis-libelf-devel rpm package ,i got to know it needed elfutils-libelf-devel-static which i decided to install first, this led to the latter needing other packages also ,i'm kind of confused
      can anyone tell me what is happening here?

      [root@localhost oracle]# rpm -ivh /media/'Enterprise Linux dvd 20100405'/Server/elfutils-libelf-devel-0.137-3.el5.x86_64.rpm
      warning: /media/Enterprise Linux dvd 20100405/Server/elfutils-libelf-devel-0.137-3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
      error: Failed dependencies:
      elfutils-libelf-devel-static-x86_64 = 0.137-3.el5 is needed by elfutils-libelf-devel-0.137-3.el5.x86_64


      [root@localhost oracle]# rpm -ivh /media/'Enterprise Linux dvd 20100405'/Server/elfutils-devel-static-0.137-3.el5.x86_64.rpm
      warning: /media/Enterprise Linux dvd 20100405/Server/elfutils-devel-static-0.137-3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
      error: Failed dependencies:
      elfutils-devel-x86_64 = 0.137-3.el5 is needed by elfutils-devel-static-0.137-3.el5.x86_64
      elfutils-libelf-devel-static-x86_64 = 0.137-3.el5 is needed by elfutils-devel-static-0.137-3.el5.x86_64

      [root@localhost oracle]# rpm -ivh /media/'Enterprise Linux dvd 20100405'/Server/elfutils-devel-0.137-3.el5.x86_64.rpm
      warning: /media/Enterprise Linux dvd 20100405/Server/elfutils-devel-0.137-3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159
      error: Failed dependencies:
      elfutils-devel-static-x86_64 = 0.137-3.el5 is needed by elfutils-devel-0.137-3.el5.x86_64
      elfutils-libelf-devel-x86_64 = 0.137-3.el5 is needed by elfutils-devel-0.137-3.el5.x86_64
      elfutils-libs-x86_64 = 0.137-3.el5 is needed by elfutils-devel-0.137-3.el5.x86_64
      libasm.so.1()(64bit) is needed by elfutils-devel-0.137-3.el5.x86_64
      libdw.so.1()(64bit) is needed by elfutils-devel-0.137-3.el5.x86_64