2 Replies Latest reply on Aug 11, 2010 11:41 AM by 790318

    BEA-380000: Not Implemented

    790318
      Hi...

      In my proxy I'm making a request to a webservice (published by siebel) and I'm getting the following error:

      <con:fault xmlns:con="http://www.bea.com/wli/sb/context">
      <con:errorCode>BEA-380000</con:errorCode>
      <con:reason>Not Implemented</con:reason>
      <con:location>
      <con:node>RouteNode1</con:node>
      <con:path>response-pipeline</con:path>
      </con:location>
      </con:fault>

      I can contact the webservice form soapUI and from other applications with no problem but when I try to invoke it from OSB it gives the above error.

      If I test my business file with the given WSDL and run it on osb workshop (run on server) I get the following response:

      Response Document

      The invocation resulted in an error: Not Implemented.

      Response Metadata

      <con:metadata xmlns:con="http://www.bea.com/wli/sb/test/config">
      <tran:headers xsi:type="http:HttpResponseHeaders" xmlns:http="http://www.bea.com/wli/sb/transports/http" xmlns:tran="http://www.bea.com/wli/sb/transports" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <tran:user-header name="Expires" value="Wed, 11 Aug 2010 11:14:01 GMT"/>
      <tran:user-header name="Mime-Version" value="1.0"/>
      <tran:user-header name="X-Cache" value="MISS from ebox.critical.pt"/>
      <tran:user-header name="X-Squid-Error" value="ERR_UNSUP_REQ 0"/>
      <http:Connection>close</http:Connection>
      <http:Content-Length>1096</http:Content-Length>
      <http:Content-Type>text/html</http:Content-Type>
      <http:Date>Wed, 11 Aug 2010 11:14:01 GMT</http:Date>
      <http:Server>squid/2.5.STABLE13</http:Server>
      </tran:headers>
      <tran:response-code xmlns:tran="http://www.bea.com/wli/sb/transports">1</tran:response-code>
      <tran:response-message xmlns:tran="http://www.bea.com/wli/sb/transports">Not Implemented</tran:response-message>
      <tran:encoding xmlns:tran="http://www.bea.com/wli/sb/transports">iso-8859-1</tran:encoding>
      <http:http-response-code xmlns:http="http://www.bea.com/wli/sb/transports/http">501</http:http-response-code>
      </con:metadata>


      ----------------------------------------

      I'm using oracle service bus version 11.1.1.3
      I already tested all option's combinations and I have no idea on what's wrong.
      Any help would be very appreciated, even if it's just a hint on where to look...

      Thanks in advance.