1 2 Previous Next 25 Replies Latest reply: Aug 12, 2010 12:13 PM by sb92075 RSS

    MEMORY_TARGET not supported on this system

    781089
      Hi, I have had some problems with the RAM in my PC (im running 11g/r2 on OEL 5.5 ) ....

      Origionaly the PC had 8gb ram, but one of the 2g sticks became faulty so i had to remove it, reducing the system to 6gb.... now when i try and startup oracle i get the following message:

      --------------------------

      SQL> connect / as sysdba
      Connected to an idle instance.
      SQL> startup;
      ORA-00845: MEMORY_TARGET not supported on this system

      --------------------------

      can someone help me please?
        • 1. Re: MEMORY_TARGET not supported on this system
          Dom Brooks
          What have you set MEMORY_TARGET & MEMORY_MAX_TARGET to?
          And what's the size of /dev/shm?
          • 2. Re: MEMORY_TARGET not supported on this system
            sb92075
            00845, 00000, "MEMORY_TARGET not supported on this system"
            // *Cause: The MEMORY_TARGET parameter was not supported on this operating system or /dev/shm was not sized correctly on Linux.
            // *Action: Refer to documentation for a list of supported operating systems. Or, size /dev/shm to be at least the SGA_MAX_SIZE on each Oracle instance running on the system.
            • 3. Re: MEMORY_TARGET not supported on this system
              gjilevski1
              Hi,

              Please look at:

              http://www.oraclealchemist.com/oracle/strange-behavior-with-memory_target/


              Make sure the shared memory filesystem is big enough for Automatic Memory Manager to work.

              # umount tmpfs
              # mount -t tmpfs shmfs -o size=1500m /dev/shm

              Regards,
              • 4. Re: MEMORY_TARGET not supported on this system
                781089
                Im totally lost looking at all these links... i have messed up my pc big time trying to sort this out...

                could someone please help me on the commands i need to run ...

                I previously had 8gb ram in my pc, ... at this point evrything worked fine....

                I have had to take 2gb and this is now when im getting prblems starting oracle...

                any help would be appriciated
                • 5. Re: MEMORY_TARGET not supported on this system
                  gjilevski1
                  Hi,

                  What is df -k showing for the shared memory filesystem?



                  Make sure the shared memory filesystem is big enough for Automatic Memory Manager to work.

                  # umount tmpfs
                  # mount -t tmpfs shmfs -o size=1500m /dev/shm

                  Regards,
                  • 6. Re: MEMORY_TARGET not supported on this system
                    781089
                    Filesystem 1K-blocks Used Available Use% Mounted on
                    /dev/mapper/VolGroup00-LogVol00
                    141376216 28496448 105582336 22% /
                    /dev/sdb1 101086 16442 79425 18% /boot
                    tmpfs 2987692 0 2987692 0% /dev/shm
                    [matt@localhost ~]$

                    ----------------------------

                    [matt@localhost ~]$ su - root
                    Password:
                    [root@localhost ~]# umount tmpfs
                    [root@localhost ~]# mount -t tmpfs shmfs -o size=1500m /dev/shm

                    ----------------------

                    so what should i do sorry?

                    Edited by: user9200169 on Aug 12, 2010 4:12 AM
                    • 7. Re: MEMORY_TARGET not supported on this system
                      781089
                      im still getting the following error:

                      SQL*Plus: Release 11.2.0.1.0 Production on Thu Aug 12 13:13:08 2010

                      Copyright (c) 1982, 2009, Oracle. All rights reserved.

                      SQL> SQL> connect / as sysdba
                      Connected to an idle instance.
                      SQL> startup;
                      ORA-00845: MEMORY_TARGET not supported on this system
                      • 8. Re: MEMORY_TARGET not supported on this system
                        Marco V.
                        This is what happened to me and how I solved.
                        The problem is the same.

                        http://dbaworkshop.blogspot.com/2010/04/11gr2-setup-larger-devshm-after-ora.html
                        • 9. Re: MEMORY_TARGET not supported on this system
                          781089
                          thanks but i have allready looked at that and totally messed up my pc trying to follow it
                          • 10. Re: MEMORY_TARGET not supported on this system
                            791023
                            hi ,

                            Please check given below steps :

                            ORA-00845: MEMORY_TARGET not supported on this system
                            Problem Description
                            While creating a startup database using dbca the database creation GUI gives error message in a pop up window,
                            ORA-00845: MEMORY_TARGET not supported on this system
                            from where you can ignore the error message.
                            The similar scenario also occur whenever you try to start your database then startup shows error message like below.

                            SQL> STARTUP
                            ORA-00845: MEMORY_TARGET not supported on this system

                            Cause of the Problem
                            •Starting from Oracle 11g the automatic memory management feature is now defined with parameter MEMORY_TARGET and MEMMORY_MAX_TARGET.

                            •On linux file system the shared memory need to be mounted on /dev/shm directory on the operating system.

                            •And the size of /dev/shm needs to be greater than MEMORY_TARGET or MEMMORY_MAX_TARGET.

                            •The AMM (Automatic Memory Management) now in 11g manages both SGA and PGA together by MMAN process.

                            •The MEMORY_TARGET parameter in 11g comes for (SGA_TARGET+PGA_AGGREGATE_TARGET) which was in 10g.

                            •And MEMORY_MAX_TARGET parameter in 11g comes instead of SGA_MAX_TARGET parameter which was in 10g.

                            •The ORA-00845:can arises for the following two reasons on linux system.

                            1)If the shared memory which is mapped to /dev/shm directory is less than the size of MEMORY_TARGET or MEMORY_MAX_TARGET.
                            or,
                            2)If the shared memory is not mapped to /dev/shm directory.

                            Solution of the Problem
                            Make sure /dev/shm is properly mounted. You can see it by,
                            #df -h or #df -k command.
                            The output should be similar like

                            $ df -k
                            Filesystem Size Used Avail Use% Mounted on
                            ...
                            shmfs 1G 512M 512M 50% /dev/shm


                            We see here for /dev/shm we have assigned 1G memory. Now if you set MEMORY_TARGET more than 1G then above ORA-845 will arise. For example if you have MEMORY_TARGET or MEMORY_MAX_TARGET set to 12G then you can mount shared memory to 13g like below.
                            As a root user,
                            # mount -t tmpfs shmfs -o size=13g /dev/shm
                            In order to make the settings persistence so that it will affect after restarting machine add an entry in /etc/fstab similar to the following:

                            shmfs /dev/shm tmpfs size=13g 0

                            This is given in:
                            http://arjudba.blogspot.com/2009/01/ora-00845-memorytarget-not-supported-on.html link.
                            • 11. Re: MEMORY_TARGET not supported on this system
                              gjilevski1
                              Hi,

                              Try to increase the value:

                              mount -t tmpfs shmfs -o size=3500m /dev/shm

                              if does not work increase further

                              mount -t tmpfs shmfs -o size=5500m /dev/shm

                              Also make sure memory_target and memory_max_target is less that the value above.

                              Regards

                              Edited by: gjilevski1 on Aug 12, 2010 4:21 AM
                              • 12. Re: MEMORY_TARGET not supported on this system
                                Aman....
                                Hope I won't add anything to your confusion. AMM uses the /dev/shm so the tempfs on your machine should be large enough to hold your sga. Show us the output like the following command and also tell us that what's the SGA size (MEMORY_TARGET) that you have for your db?
                                [oracle@edhdr2p0-orcl ~]$ df -k
                                Filesystem           1K-blocks      Used Available Use% Mounted on
                                /dev/sda5            202739860  45487620 146787504  24% /
                                /dev/sda2                23332      6844     15284  31% /boot
                                tmpfs                  1032668    395004    637664  39% /dev/shm
                                /dev/sda1             30694288  14683096  16011192  48% /mnt/cdrive
                                HTH
                                Aman....
                                • 13. Re: MEMORY_TARGET not supported on this system
                                  791023
                                  tmpfs 2987692 0 2987692 0% /dev/shm

                                  this means you have 2987692 bytes check value for MEMORY_TARGET/MEMORY_MAX_TARGET. You can not set MEMORY_TARGET>2987692.

                                  Check value of MEMORY_TARGET or MEMORY_MAX_TARGET.

                                  and after that
                                  do
                                  umount tmpfs
                                  mount -t tmpfs shmfs -o size=(Value Greater than value of Memory_target) /dev/shm


                                  Regards
                                  Rajinder
                                  • 14. Re: MEMORY_TARGET not supported on this system
                                    781089
                                    how do i check value for memory target and memory max?
                                    1 2 Previous Next