4 Replies Latest reply on Aug 19, 2010 9:03 PM by Kris Rice-Oracle

    listenerConfigure not rendering correctly

    rizwanarshad
      Hi,

      I have just deployed the APEX Listener app into OC4J 10.1.3.5 (SOA Suite) and I have created the required roles and users.

      I have modified the OC4J to startup using JDK 1.6.0 u21 (64-bit).

      However when I access the listener configuration page http://<server>/apex/listenerConfigure all that is displayed in my browser is the content of the adminTemplate.html file, i.e. the page is not correctly rendered.

      Am I missing some configuration?

      Thanks,
      Riz
        • 1. Re: listenerConfigure not rendering correctly
          rizwanarshad
          I am using the following versions:

          APEX Listener: 1.10.179.10.43

          APEX: 3.2.1

          Can the APEX Listener only be used with APEX 4.0?
          • 2. Re: listenerConfigure not rendering correctly
            Kris Rice-Oracle
            I've never seen that is there anything in the log files?
            -kris
            • 3. Re: listenerConfigure not rendering correctly
              rizwanarshad
              The application.log doesn't contain anything useful:

              10/08/13 22:04:13.157 apex: 10.1.3.5.0 Started
              10/08/13 22:18:49.37 apex: 10.1.3.5.0 Stopped
              10/08/14 00:17:41.219 10.1.3.5.0 Started
              10/08/14 00:17:55.229 apex: 10.1.3.5.0 Started

              The OPMN log file for the OC4J process (default_group~apex~default_group~1.log) contains:

              --------
              10/08/14 00:17:11 Start process
              --------
              Aug 14, 2010 12:17:31 AM com.evermind.server.XMLDataSourcesConfig parseRootNode
              INFO: Legacy datasource detected...attempting to convert to new syntax.
              10/08/14 00:17:55 WARNING: Code-source /u01/oracle/product/10gAS/10g_J2EE/j2ee/apex/applications/apex/apex/WEB-INF/lib/ojmisc.jar (from WEB-INF/lib/ directory in /u01/oracle/product/10gAS/10g_J2EE/j2ee/apex/applications/apex/apex/WEB-INF/lib) has the same filename but is not identical to /u01/oracle/product/10gAS/10g_J2EE/jlib/ojmisc.jar (from <code-source> in META-INF/boot.xml in /u01/oracle/product/10gAS/10g_J2EE/j2ee/home/oc4j.jar). If it contains different versions of the same classes, it will be masked as the latter is already visible in the search path of loader apex.web.apex:0.0.0.
              10/08/14 00:17:55 Oracle Containers for J2EE 10g (10.1.3.5.0) initialized
              10/08/14 00:19:40 Using Config file:/home/oracle/apex/apex-config.xml
              • 4. Re: listenerConfigure not rendering correctly
                Kris Rice-Oracle
                I just posted a new version. Can you try this and see if you get the same issue?
                -kris