3 Replies Latest reply on Aug 18, 2010 2:05 PM by Srini Chavali-Oracle

    Oracle 10g R2 Installation Error

    785665
      I got the error When I tried to run the Oracle installler.
      I run the Xhost + also.

      I am using OEL 5.5 , So I changed the /etc/redhat-release file with Redhat-4, So I overcome the compatible error. But the following Occurs:

      -----------------------------------------------------------------------------------------------------------------------------------------------------------------
      [oracle@localhost Oracle10gR2]$ ./runInstaller
      Starting Oracle Universal Installer...

      Checking installer requirements...

      Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2
      Passed


      All installer requirements met.

      Preparing to launch Oracle Universal Installer from /tmp/OraInstall2010-08-18_04-01-15PM. Please wait ...[oracle@localhost Oracle10gR2]$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /tmp/OraInstall2010-08-18_04-01-15PM/jre/1.4.2/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
      at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      at java.lang.ClassLoader.loadLibrary0(Unknown Source)
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at sun.security.action.LoadLibraryAction.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.awt.NativeLibLoader.loadLibraries(Unknown Source)
      at sun.awt.DebugHelper.<clinit>(Unknown Source)
      at java.awt.Component.<clinit>(Unknown Source)
      [oracle@localhost Oracle10gR2]$

      ------------------------------------------------------------------------------------------------------------------------------------------------------------

      So, how to overcome this?
        • 1. Re: Oracle 10g R2 Installation Error
          rajeysh
          check the required packages (rpms)
          install the following packages whilst logged in as the root user. This includes the 64-bit and 32-bit versions of some packages.
          rpm -Uvh binutils-2.*
          rpm -Uvh compat-libstdc++-33*
          rpm -Uvh elfutils-libelf-0.*
          rpm -Uvh elfutils-libelf-devel-*
          rpm -Uvh gcc-4.*
          rpm -Uvh gcc-c++-4.*
          rpm -Uvh glibc-2.*
          rpm -Uvh glibc-common-2.*
          rpm -Uvh glibc-devel-2.*
          rpm -Uvh glibc-headers-2.*
          rpm -Uvh ksh-2*
          rpm -Uvh libaio-0.*
          rpm -Uvh libaio-devel-0.*
          rpm -Uvh libgcc-4.*
          rpm -Uvh libstdc++-4.*
          rpm -Uvh libstdc++-devel-4.*
          rpm -Uvh make-3.*
          rpm -Uvh sysstat-7.*
          rpm -Uvh unixODBC-2.*
          rpm -Uvh unixODBC-devel-2.*

          Add or amend the following lines to the "/etc/sysctl.conf" file.

          fs.aio-max-nr = 1048576
          fs.file-max = 6815744
          kernel.shmall = 2097152
          kernel.shmmax = 536870912
          kernel.shmmni = 4096
          # semaphores: semmsl, semmns, semopm, semmni
          kernel.sem = 250 32000 100 128
          net.ipv4.ip_local_port_range = 9000 65500
          net.core.rmem_default=262144
          net.core.rmem_max=4194304
          net.core.wmem_default=262144
          net.core.wmem_max=1048586

          Login as the oracle user and add the following lines at the end of the .bash_profile file.
              # Oracle Settings
              TMP=/tmp; export TMP
              TMPDIR=$TMP; export TMPDIR
          
              ORACLE_BASE=/u01/app/oracle; export ORACLE_BASE
              ORACLE_HOME=$ORACLE_BASE/product/10.2.0/db_1; export ORACLE_HOME
              ORACLE_SID=RAC1; export ORACLE_SID
              ORACLE_TERM=xterm; export ORACLE_TERM
              PATH=/usr/sbin:$PATH; export PATH
              PATH=$ORACLE_HOME/bin:$PATH; export PATH
          
              LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib; export LD_LIBRARY_PATH
              CLASSPATH=$ORACLE_HOME/JRE:$ORACLE_HOME/jlib:$ORACLE_HOME/rdbms/jlib; export CLASSPATH
          
              if [ $USER = "oracle" ]; then
                if [ $SHELL = "/bin/ksh" ]; then
                  ulimit -p 16384
                  ulimit -n 65536
                else
                  ulimit -u 16384 -n 65536
                fi
              fi
          • 2. Re: Oracle 10g R2 Installation Error
            rajeysh
            install missing packages rpm's will solve your problem.

            hope, this will helps you.

            all the best for your installation.

            Rajeshkumar Govindarajan.
            http://oracleinstance.blogspot.com
            • 3. Re: Oracle 10g R2 Installation Error
              Srini Chavali-Oracle
              This issue has been discussed many times before in this forum - pl use the search feature to find old threads and resolutions.

              http://forums.oracle.com/forums/search.jspa?threadID=&q=libawt.so%3A+libXp.so.6&objID=f64&dateRange=thisyear&userID=&numResults=15

              HTH
              Srini