7 Replies Latest reply on Aug 25, 2010 12:44 PM by Dude!

    .src.rpm for OEL 5.5

    RedRose
      hello

      I am talking about the openmotif-2.3.1-2.el5_4.1.src.rpm
      format it is .src. how to run source RPM which in above format.

      I had used rpm -i openmotif-2.3.1-2.el5_4.1.src.rpm
      error: cannot create %sourcedir /usr/src/redhat/SOURCES

      yum install glibc-2.5-49.src.rpm
      Loaded plugins: security
      Setting up Install Process
      Examining glibc-2.5-49.src.rpm: glibc-2.5-49.src
      Cannot add package glibc-2.5-49.src.rpm to transaction. Not a compatible architecture: src
      I am getting this above error
      pls. let know the same.

      These are the folders are the in DVD of Source just for your information

      EULA GPL RPM-GPG-KEY SRPMS TRANS.TBL
      I am doing for the first time that is why i am asking
      Tks/regs
      Sunil
        • 1. Re: .src.rpm for OEL 5.5
          Dude!
          Are you sure you want to install source code to recompile?

          You can download the SRPMS packages from:

          ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/
          http://oss.oracle.com/el5/

          However, if you just need to install Open Motif development libraries and header files:

          You might want to try the following (as root)

          cd /etc/yum.repos.d
          wget http://public-yum.oracle.com/public-yum-el5.repo

          Then edit the file and set the following sections to enabled=1

          vi public-yum-el5.repo

          el5_u5_base
          el5_addons
          el5_oracle_addons

          After that do the following:

          yum clean all
          yum update

          yum list openmotif*

          yum install openmotif-devel
          • 2. Re: .src.rpm for OEL 5.5
            RedRose
            Hello

            IT ORACLE ENTERPRISE LINUX 5.5 JUST I DOWNLOADED THE LINUX IT IS ASKING FOR RPMS IN ORDER TO INSTALL R12. Even I downloaded source dvd from edlivery for the sake of RPMS but source dvd it is in the format of .src.rpm for OEL 5.5

            I had tried as per your suggestion below showing the result of the output.

            [root@oracle yum.repos.d]# vi public-yum-el5.repo.5
            [root@oracle yum.repos.d]# yum clean all
            Loaded plugins: security
            Cleaning up Everything
            [root@oracle yum.repos.d]# yum update
            Loaded plugins: security
            el5_ga_base | 1.1 kB 00:00
            el5_ga_base/primary | 720 kB 00:10
            el5_ga_base 3204/3204
            Skipping security plugin, no data
            Setting up Update Process
            No Packages marked for Update
            [root@oracle yum.repos.d]#
            2nd i tried to check he package installed or not the result of the output
            [root@oracle yum.repos.d]# rpm -q gcc-4.1.2-14.el5
            package gcc-4.1.2-14.el5 is not installed
            [root@oracle yum.repos.d]# rpm -q gcc-c++-4.1.2-14.el5
            package gcc-c++-4.1.2-14.el5 is not installed



            hoping your reply

            Tks/regs
            Sunil

            Edited by: RedRose on Aug 23, 2010 11:33 PM

            Edited by: RedRose on Aug 23, 2010 11:37 PM
            • 3. Re: .src.rpm for OEL 5.5
              Dude!
              I see that you have the same question already posted in Installation R12 on OEL 5.5 and someone is taking care of.

              RPM and YUM are not the same thing and used in different ways.

              You don't need to install source code. What do you receive typing the following:

              yum list gcc
              yum install gcc

              Since you have setup the yum repository now to fetch the packages from the internet, you can use the same also for other packages, e.g.:
              # yum install glibc-devel
              Loaded plugins: security
              Setting up Install Process
              Package glibc-devel-2.5-49.x86_64 already installed and latest version
              Package glibc-devel-2.5-49.i386 already installed and latest version
              Nothing to do
              
              # yum install glibc
              Loaded plugins: security
              Setting up Install Process
              Package glibc-2.5-49.x86_64 already installed and latest version
              Package glibc-2.5-49.i686 already installed and latest version
              Nothing to do
              If the packages are already installed there is nothing to do, otherwise it will prompt you.

              P.S. did yum list openmotif* as outlined above work for you? yum update will only update currently installed packages. For more info:
              # man yum
              # info yum

              Edited by: Markus Waldorf on Aug 24, 2010 1:18 AM
              • 4. Re: .src.rpm for OEL 5.5
                RedRose
                Hello Sir,

                [root@oracle yum.repos.d]# yum install glibc-devel-2.5-12
                Loaded plugins: security
                Setting up Install Process
                No package glibc-devel-2.5-12 available.
                Nothing to do
                [root@oracle yum.repos.d]# yum install libgcc-4.1.2-14.el53
                Loaded plugins: security
                Setting up Install Process
                No package libgcc-4.1.2-14.el53 available.
                Nothing to do
                when I trying to install above rpm it is showing above message.Pls. direct me for issue to proeed further

                Oracle Enterprise Linux 5*:

                Update 1 (5.1) or higher of Oracle Enterprise Linux (OEL) 5 is required

                Update 1 (5.1) or higher of Red Hat Enterprise Linux (RHEL) 5 is required

                The following i386 packages are not part of the OS distribution media and must be downloaded separately (from http://oss.oracle.com/projects/compat-oracle/files/Enterprise_Linux for both OEL 5 and RHEL 5) and installed manually:

                2. * openmotif21-2.1.30-11.EL5.i3861
                * xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386
                * For Update 1 or 2:
                o binutils-2.17.50.0.6-6.0.1.i3862
                * For Update 3:
                o binutils-2.17.50.0.6-9.0.1.i3862
                * For Update 4 (5.4) or higher, see workaround listed below in the ‘After Installing or Upgrading’ section.

                The following i386 packages must be installed from the OEL 5 or RHEL 5 distribution media:

                * compat-glibc-2.3.4-2.26
                * gcc-4.1.2-14.el5
                * gcc-c++-4.1.2-14.el5
                * glibc-2.5-123
                * glibc-common-2.5-123
                * glibc-devel-2.5-12
                * libgcc-4.1.2-14.el53
                * libstdc++-devel-4.1.2-14.el5
                * libstdc++-4.1.2-14.el53
                * make-3.81-1.13
                * gdbm-1.8.0-26.2.13
                * libXp-1.0.0-8.1.el5
                * libaio-0.3.106-3.23
                * libgomp-4.1.2-14.el5
                * sysstat-7.0.0-3.el5
                * compat-libstdc++-296-2.96-138
                * compat-libstdc++-33-3.2.3-6






                Thanks/regs
                Sunil

                Edited by: RedRose on Aug 24, 2010 10:17 AM
                • 5. Re: .src.rpm for OEL 5.5
                  Dude!
                  Why do you continue to type the version number of packages - simply don't.

                  glibc-devel-2.5-12 was the requirement at the time the instructions were written, but the package has meanwhile been updated to glibc-2.5-49.

                  You are using YUM to fetch the packages from the internet, which wants a package name, and not RPM to install a package file from your disk or DVD.

                  So you would simply type:

                  yum install glibc-devel
                  yum install glibc
                  yum install glibc-common

                  or

                  yum install glibc*

                  which will install all the above at once.

                  It will automatically fetch the latest available package for your version of OEL (just like I outlined in the previous reply).

                  Then you simply answer "y" at the prompt to install the packages.

                  Same goes for the rest:

                  yum install compat*
                  yum install gcc-c++
                  yum install gcc
                  yum install openmotif*
                  yum install systat
                  yum install make
                  yum install libstdc++*
                  yum install gdbm
                  yum install libXp

                  etc.

                  Give it a try.

                  Edited by: Markus Waldorf on Aug 24, 2010 12:49 PM
                  • 6. Re: .src.rpm for OEL 5.5
                    RedRose
                    Hello Markus Waldorf

                    Thanks for your information and following up for my query
                    I could able to do the same.
                    Thanks/regs
                    Sunil
                    • 7. Re: .src.rpm for OEL 5.5
                      Dude!
                      Glad to hear. I guess it was a somewhat difficult birth, but there had to be way. Please reward answers with points (as "helpful" - 5 pts - or "correct" - 10pts). Thanks. Good luck with the rest of the installation.