8 Replies Latest reply on Jun 6, 2013 3:50 PM by K Cannell

    Error while loging in Application

    jose a
      Hello

      APEX 4.0.1

      Afther change from http server connection mode to Apex Listener.

      We can log in Admin APEX, Development APEX, but when we try to log an application that continue working throught http server fail when try to log throught APEX Listener

      Resume.

      Enviroment 1

      Proxy Reverse - Oracle Http Server - Database is OK.

      Enviroment 2

      Proxy Reverse - Oracle APEX LISTENER in Oracle WebLogic Server - Database give error.

      Errror.

      Expecting p_company or wwv_flow_company cookie to contain security group id of application owner.
      Error ERR-7621 Could not determine workspace for application (:) on application accept.
      OK

      Thx.
      Jose A. Rodriguez
        • 1. Re: Error while loging in Application
          Udo
          Hi Jose,

          it appears that the cookie handling with APEX Listener is a bit more difficult than it is with a "simple" HTTP server.
          Do you use a custom authentication scheme?

          Does your proxy pass cookies as well? ( directive would be ProxyPassReverseCookiePath /apex ... )
          You could check with printing the output of
          owa_util.get_cgi_env( 'HTTP_COOKIE' );

          This should contain a lot of information about your session, like the LOGIN_USERNAME_COOKIE or some WWV_CUSTOM-F*-attribute to identify your custom session.

          If you don't get a result your cookie probably got blocked somewhere in between. You could check, if cookies are enabled on WebLogic. As far as I know you can configure this for different scopes (global and context-based).

          -Udo

          Edited by: Udo on 05.09.2010 19:29
          You might be interested in following this thread: Bug?: ERR-7621 on  Apex 3.2,  XE and Apexlistener+Glassfish;
          • 2. Re: Error while loging in Application
            jose a
            H,

            Do you use a custom authentication scheme?
            No we do not use custom auth scheme.

            Does your proxy pass cookies as well? ( directive would be ProxyPassReverseCookiePath /apex ... )

            We check to log directly to weblogic server, and we obtain same error.

            http://rhdesajava.bec.eu:7003/apex/wwv_flow.accept

            Expecting p_company or wwv_flow_company cookie to contain security group id of application owner.
                 Error      ERR-7621 Could not determine workspace for application (:) on application accept.
            OK      



            Thx.
            • 3. Re: Error while loging in Application
              jose a
              Hello,

              I redeploy the server with apex_listener.1.10.179.10.43 version instead of the last apex_listener.1.0.2.238.15.24, and work perfectly.

              Seems a problem of version apex_listener.1.0.2.238.15.24, or it is necesary to do something special.

              Thx.
              • 4. Re: Error while loging in Application
                jose a
                Hello,

                Checked that problem with apex_listener.1.1.EA and continue the same error,

                For surprise Second solution change the Theme od the application resolve the problem too..... ....

                Our theme bugged, theme 9 Underlined


                Thx.
                • 5. Re: Error while loging in Application
                  Fahd.Mirza
                  I think you need to set the value of PlsqlNLSLanguage ind Dads.conf to the same values like the database.

                  regards
                  • 6. Re: Error while loging in Application
                    Udo
                    Hello Fahd,

                    seems you overlooked that this is the APEX Listener Forum and the posted issue is actually a problem with the APEX Listener. As you probably know, the APEX Listener is a replacement for using OHS/mod_plsql, so there is no dads.conf and (currently) no PlsqlNLSLanguage parameter.

                    -Udo
                    • 7. Re: Error while loging in Application
                      685473
                      Just like Jose I am also facing the ERR-7621 message.
                      After I log in an Apex 3.2.1 application with theme 9 in combination with the Apex listener 1.1 or 1.0.2 the error is shown.
                      Glassfish or Tomcat Apache doesn't matter.
                      With an older version of the war file of Apex listener or in combination with the HTTP server the application runs without the error message.

                      You can simple test it by creating a new application in Apex 3.2.1 with just 1 blank page, one level of tabs, no shared components, database authentication and theme 9
                      - Run the application using the HTTP server and it will show page 1 after logon.
                      - Run the application using the Apex listener and it will after logon return the message:
                      Expecting p_company or wwv_flow_company cookie to contain security group id of application owner.
                           Error      ERR-7621 Could not determine workspace for application (:) on application accept.

                      If you create an application in the same way in Apex 4.0 you will notice that it works normally.

                      It appears to me that the template of the login page of theme 9 of Apex 3.2.1 contains a bug
                      Looking at this template you will notice that header as well as the body contains the code: <body #ONLOAD#>#FORM_OPEN#
                      Remove the one from the header and the application will work as expected.

                      I am not a big expert on the Apex templates.
                      So if somebody has a better suggestion. Please feel free to comment on this thread.

                      Regards,

                      Mathieu
                      • 8. Re: Error while loging in Application
                        K Cannell
                        Found the same thing on my setup - APEX 4.1, APEX Listener 2.0.2, Glassfish Open Source.

                        In my case, using an old theme, the double #FORM_OPEN# was in the Login page theme.
                        Removed the extra #FORM_OPEN# and all is OK now.

                        Hope this helps someone else -
                        Karen