10 Replies Latest reply: Sep 16, 2010 9:53 AM by Michael Ferrante-Oracle RSS

    FRM-41214

    797473
      Hello

      I have a problem with calling reports from forms. FRM-41214.

      I have a windows 2003 r2 SP2 machine. And pfrd 11.1.1.3

      I start the forms from "Admin Server Console". The Forms-Server start over a "Node Manager" in the background.

      When i start the forms-serivce with the "StartManagedWebLogic.cmd" as a separate shell in the forground then the call from my reports work fine.

      Many thanks
      Martin
        • 1. Re: FRM-41214
          Michael Ferrante-Oracle
          Check the Reports Queue Status page. You will likely see a red X for the job that failed. Click on the X and you will see why exactly it failed.

          You can access the page with a url similar to this. If you are using a stand-alone Rep server you will need to add the server name to the end.


          http://<SERVER NAME>:9002/reports/rwservlet/showjobs?

          If you have a stand-alone rep server:

          http://<SERVER NAME>:9002/reports/rwservlet/showjobs?server=<REP SERVER NAME>

          It is likely that the path to the report is missing. You can try to add the complete path to the report in the form (for testing purposes). If that fixes the problem, you will need to update the Reports config to include the path to the Reports (.rdf, .rep, etc)
          • 2. Re: FRM-41214
            797473
            In the Reports Queue is not a new entry. When i start the reports from url, then in the queue is a successfully entry for this reports. Also when i start forms-server as a shell (not as a service) then there is a successfully entry.

            I checked also all the logfiles (the hole weblogic instance) in this time-periode, but i coudn't found any fourher information.

            I have also changed my reports config file with the correct path (variable sourcedir). The start for a report with an url works fine, without add the full path for the report.
            • 3. Re: FRM-41214
              Sarah
              hi


              try to clean the cache memory and also if possible please increase the cache Memory..
              then try.....

              sarah
              • 4. Re: FRM-41214
                797473
                You say "clean the cache memory ". Can you give more details.

                I tried to delete all pdf's in reports-query.

                I trie to delete the internet files within java-cache (But i have the same error on different client. So i'm sure that isn't the java-cache.

                Mean you in webcache? (But i haven't found any documentation to delete and increase a cache memory)

                Mean you parameters in reports or forms (perhaps in admin server console) ? (But i haven't found any documentation to delete and increase a cache memory)

                Martin
                • 5. Re: FRM-41214
                  Christian Erlinger
                  It works when you starting it via the batch file and it doesn't work when you start it as a service...did you try to start the service with your account instead of the local system account?

                  cheers
                  • 6. Re: FRM-41214
                    797473
                    Yes. I start all my oracle jobs as my account.

                    For the start i have 2 methods to start in background.
                    -start with nodemanager from admin server console
                    -created a service with beasvc

                    When i look in the taskmanager, all proccesses are from my account not from "local system" account
                    • 7. Re: FRM-41214
                      Christian Erlinger
                      As I can see here: http://download.oracle.com/docs/cd/E14571_01/web.1111/e13708/winservice.htm#i1186211 you need to set some environment variables for installing the WLS instances as services. Maybe you need them for runtime too?

                      cheers
                      • 8. Re: FRM-41214
                        797473
                        Thanks for the reply

                        i installed the service based on the note ID 1060058.1. I read that this is very comparable with the chapiter "3 Setting Up a WebLogic Server Instance as a Windows Service". And it looks to be the same parameters for installsvc.cmd
                        • 9. Re: FRM-41214
                          Christian Erlinger
                          I just went through the steps in the note and installed the admin server and the 2 managed weblogic server as services (this was on my 2do list anyway, thanks for providing the note ;) ); all are working correct.

                          My setup:
                          OFMW 11.1.1.3 (I installed Forms, Reports and Discoverer with Apache and Webcache) on a Windows Server 2008 SP2 Standard 32 bit; all services are running with the local system account.

                          Did you try to redirect the stdout to a textfile like it was mentioned in the note? Maybe it gives some infos?

                          cheers
                          • 10. Re: FRM-41214
                            Michael Ferrante-Oracle
                            If you are not seeing the related entry in the Reports Queue under "Past Jobs" this means the request never made it to Reports. Which likely means that you are not including the correct Rep Server name in the call or the Rep Server is not running or responding. This likely has nothing to do with environment variables or whether or not a service is set to Local System or not. This should word out-of-the-box. If not, the problem is as I stated or a problem in your code.

                            Recommendation:

                            1. Stop ALL FMw processes/services (including WLS, Node Man, OPMN, etc)
                            2. Verify that the machine has at LEAST 3 gig of RAM assuming you are only running FMw (and WLS) on this machine. If you are also running a db, you need more.
                            3. Start the processes in the following order:

                            ...... Node Manager (wait until it has completely started - you will see "started on port 5556" displayed on the last line in the DOS window when it is running.)
                            ...... Admin Server for Classic (wait until it has reached a RUNNING status)
                            ...... OPMN (this should be configured as a Windows Service - wait until it has completely started)

                            ...... Open a browser, and navigate to the WLS Console (http://<server>:7001/console) and log in.
                            ...... Navigate to the Servers page where the managed servers can be started (http://<server>:7001/console/console.portal?_nfpb=true&_pageLabel=CoreServerServerTablePage)
                            ...... Start WLS_FORMS first (wait until it has completely started)
                            ...... Start WLS_REPORTS (wait until it has completely started)


                            With everything now started, we should identify a known Rep Server name. To do this follow this path:

                            ...... Log into EM ((http://<server>:7001/em)
                            ...... Look under Farm_ClassicDomain > Reports. Notice that there are several entries. Notice the one that is something like this: ReportsServer_<HOSTNAME>_<INSTANCE NAME>

                            This is a preconfigured RepServer created during the installation. It is started when you start OPMN. Use this name when calling from Forms.

                            With the environment now running, use the above Rep Server name in your Forms app AND for testing purposes, include the full path to the report (rdf) when declaring in your form. For example:
                                       -- 
                                       SET_REPORT_OBJECT_PROPERTY(repid, REPORT_DESTYPE, CACHE);
                                       SET_REPORT_OBJECT_PROPERTY(repid, REPORT_DESFORMAT, 'HTML'); 
                                       
                                       -- Comm mode 1 = SYNCHRONOUS
                                       -- Comm mode 2 = ASYNCHRONOUS
                                       SET_REPORT_OBJECT_PROPERTY(repid, REPORT_COMM_MODE, 1);
                                       
                                       SET_REPORT_OBJECT_PROPERTY(repid, REPORT_SERVER, 'ReportsServer_myHost_asinst_1);           
                                       SET_REPORT_OBJECT_PROPERTY(repid, REPORT_FILENAME, 'C:\myReports\employees.rdf');
                                      SYNCHRONIZE;
                            
                                      -- Be sure to include the same Reports server name in the WEB.SHOW call which should occur below this part of the code.