2 Replies Latest reply: Sep 17, 2010 2:23 PM by 798537 RSS

    OALL8 is in an inconsistent state

      When I run sql in Oracle SQL Developer I often get "OALL8 is in an inconsistent state" message; if I try it again the message changes to "Protocol violation". I did a research on Internet, it said " If there are multiple ORACLE_HOME versions installed on the same PC as SQL Developer the wrong JDBC driver might be loaded". I followed the solution: created a sqldeveloper.cmd file in the SQL Developer root directory with the following contents:
      start sqldeveloper.exe

      But it didn't solving the issue.

      Please help!
      Many thanks.
        • 1. Re: OALL8 is in an inconsistent state
          I want to say that is the error that I use to see when:
          - SQL Developer lost it's connection to Oracle
          - SQL Developer thought it was still connected
          - I ran a query or tired to open a new object from the navigation tree.

          But it's been a while since it's happened. These days I know when the database is shutting down and disconnect/reconnect before I doing anything. And even then I think it was only with older versions of SQL Developer. The latest one tells you that you've been disconnected.
          • 2. Re: OALL8 is in an inconsistent state
            Thank you very much for your reply. Let me find out why it is disconnected. Before I never got this error message until I started to run a big query on remote database. After this error message occurred, I am keeping get the same message even I run some query locally with restart the SQL Developer.
            Again thanks a lot!