2 Replies Latest reply on Sep 23, 2010 11:33 AM by Turribeach

    OPatch error

    768527
      Hello everybody.

      I'm a newbie in applying/installing Oracle patches.
      I'm trying to upgrade the Discoverer from 4i to 10g and for this I'm supposed to install this update (among others): 2291496.
      Since I didn't do this until now, I read on the Internet and I'm trying to use OPatch to install the update.
      I downloaded the file, extracted it, uploaded on the server in the oracle user's home directory.
      I logged on with the oracle user, set the $ORACLE_HOME env and tried to call the opatch apply command.

      This is the command line:

      [oracle@ispdevtst 2291496]$ /u01/oracle/ispdb/9.2.0/OPatch/opatch apply
      PERL5LIB=/u01/oracle/ispdb/9.2.0//Apache/perl/lib/5.00503:/u01/oracle/ispdb/9.2.0/OPatch/perl_modules; export PERL5LIB
      /u01/oracle/ispdb/9.2.0//Apache/perl/bin/perl /u01/oracle/ispdb/9.2.0/OPatch/opatch.pl apply
      Oracle Home = /u01/oracle/ispdb/9.2.0/
      Location of Oracle Universal Installer components = /u01/oracle/ispdb/9.2.0/oui
      Location of OraInstaller.jar = "/u01/oracle/ispdb/9.2.0/oui/jlib"
      Oracle Universal Installer shared library = /u01/oracle/ispdb/9.2.0/oui/lib/linux/liboraInstaller.so
      Location of Oracle Inventory Pointer = /etc/oraInst.loc
      Location of Oracle Inventory = /u01/oracle/ispdb/9.2.0/inventory
      Path to Java = /u01/oracle/ispdb/9.2.0/jre/1.4.2/bin/java

      oracle.ops.mgmt.cluster.ClusterInfoException: CMCLI ERROR: OpenCommPort: connect failed with error 2. /u01/oracle/ispdb/9.2.0/oui/bin/lsnodes.bin: struct size 0
      at oracle.ops.mgmt.cluster.ClusterInfo.getNodeNames(ClusterInfo.java:259)
      at oracle.sysman.oii.oiip.oiipg.OiipgVendorClusterwareInfo.isCluster(OiipgVendorClusterwareInfo.java:75)
      at oracle.sysman.oii.oiip.oiipg.OiipgDetectCluster.isCluster(OiipgDetectCluster.java:149)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at opatch.OuiDep.isCluster(OuiDep.java:96)
      at opatch.O2O.setIsCluster(O2O.java:724)
      at opatch.O2O.queryRAC(O2O.java:801)
      at opatch.O2O.setupInventoryThenRAC(O2O.java:921)
      at opatch.GetPlatformID.main(GetPlatformID.java:43)

      OPatch Version 1.0.0.0.51
      Perl Version 5.00503

      /u01/oracle/ispdb/9.2.0/OPatch/opatch.pl version: 1.0.0.0.51
      Copyright (c) 2001-2004 Oracle Corporation. All Rights Reserved.

      The patch directory area must be a number.

      ERROR: OPatch failed because of problems in patch area.
      [oracle@ispdevtst 2291496]$

      Can anyone tell what can I do or what am I doing wrong here ?

      Thank you and regards,
      Sorin Miroiu
        • 1. Re: OPatch error
          768527
          Hello.

          Nobody can help me with this problem ?

          I tried to download the latest OPatch version and install it.
          But I get a new kind of error message when I try opatch apply

          Exception in thread "main" java.lang.UnsupportedClassVersionError: oracle/opatch/OPatch (Unsupported major.minor version 48.0)
          at java.lang.ClassLoader.defineClass0(Native Method)
          at java.lang.ClassLoader.defineClass(ClassLoader.java:486)
          at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:111)
          at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
          at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
          at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:297)
          at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
          at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:313)

          OPatch failed with error code 1


          Please help me.

          Thank you and regards,
          Sorin Miroiu
          • 2. Re: OPatch error
            Turribeach
            You can start by posting the message in the right forum. This is the OBIEE forum, you should use the OBISE forum for Discoverer:

            Business Intelligence Standard Edition One