1 Reply Latest reply on Sep 27, 2010 5:46 AM by Ajinkya

    Running test.fmx

      Today I was facing to a problem on running the forms test.fmx on my oracle application server machine under Linux os. firefox ask for
      < additional plugins are required to display all the media on this page >

      As I am on the three-tier architecture, I try to run first the test.fmx forms to see if the forms component is up,before running it from the client tier. When I run http:\\<myServerName>:7778/forms/frmservlet?config=test.fmx on firefox its asking me to install the java plugin to run the applet, so to solve the prob, I followed the steps :

      Step 1: Checking java on my machine

      to check if the java is already installed on my server machine I run the java command

      [oracle@appsora ~]# java -version

      [oracle@appsora ~]#

      As the output was empty, java is not installed on my machine, so I go to step 2

      Step 2: Download and Install java

      - Download java jdk-6u23-ea-bin-b01-linux-i586-30_aug_2010-rpm.bin

      From http://download.java.net/jdk6/index.html?msgid=3-2342904058

      To /usr/java directory

      - Install java

      [root@appsora java]# chmod a x jdk-6u23-ea-bin-b01-linux-i586-30_aug_2010-rpm.bin

      [root@appsora java]# ./jdk-6u23-ea-bin-b01-linux-i586-30_aug_2010-rpm.bin

      this will create the directory jdk1.6.0_23 under /usr/java/ additional plugins are required to display all the media on this page

      you can check the version of java by running

      [root@appsora java]# jdk1.6.0_23/bin/java -version

      [root@appsora java]# java version "1.6.0_23-ea"
      Java(TM) SE Runtime Environment (build 1.6.0_23-ea-b01)
      OpenJDK Server VM (build 19.0-b06, mixed mode)

      Step 3: Now that the java is now installed on the machine we add the java plugins to firefox browser by making a link
      to java library plugin

      - [oracle@appsora ~]# cd /usr/lib/firefox-3.0.18

      - [oracle@appsora firefox-3.0.18]# cd plugins

      bash: cd: plugins: No such file or directory

      the plugins directory does not exist we must create it

      - [oracle@appsora firefox-3.0.18]# mkdir plugins

      - [root@appsora firefox-3.0.18]# cd plugins

      - [root@appsora plugins]# ln -s /usr/java/jdk1.6.0_23/jre/plugin/i386/ns7/libjavaplugin_oji.so

      the java plugins is add your firefox browser, you can check by running about:plugins on address bar or

      Menu -> Tools > add-ons - plugins

      Step 4 : last but not less running the forms test.fmx on your firefox


      If firefox is still asking you for

      additionale plugins are required to display all the media on this page

      do not worry about it, you have just to make some changes on your formsweb.cfg, because the version

      of the java plugins is not the same that's in your formsweb.cfg

      replace this the jpi_mimetype=application/x-java-applet;jpi-version=1.6.0_2

      by : jpi_mimetype=application/x-java-applet