0 Replies Latest reply: Apr 19, 2010 3:19 AM by 800573 RSS

    Strange result with jconsole

    800573
      Hi
      I am using jdk 1.6
      I am developping a web application which allow to monitor mbeans of mule ESB(mule ESB is a messaging framework , it register its components in a JMX server and i am connecting to that server by my web application)
      When i tryed to open jconsole to view the memory state of mule and tomcat i get a strange result:
      in jconsole i get 3 local process:*sun.tools.jconsole.JConsole*,*org.mule.module.boot.MuleBootstrap* and org.apache.catalina.startup.Bootstrap (until now it is OK)
      but the problem is that when i open org.apache.catalina.startup.Bootstrap i get the result of the process org.mule.module.boot.MuleBootstrap:
      for example in the VM summary tab i get:
      VM arguments: 
      -Dmule.home=C:\ESB\mule-standalone-2.2.1 -Dmule.base=C:\ESB\mule-standalone-2.2.1 -Xmx512m -Djava.library.path=%LD_LIBRARY_PATH%;C:\ESB\mule-standalone-2.2.1/lib/boot -Dwrapper.key=RxP7KEqH_wZdgqI6 -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=3660 -Dwrapper.version=3.2.3 -Dwrapper.native_library=wrapper -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1 
      Class path: 
      %MULE_LIB%;%MULE_EXE%/../conf;C:\ESB\mule-standalone-2.2.1/lib/boot/commons-cli-1.0-osgi.jar;C:\ESB\mule-standalone-2.2.1/lib/boot/jcl104-over-slf4j-1.5.0.jar;C:\ESB\mule-standalone-2.2.1/lib/boot/log4j-1.2.14.jar;C:\ESB\mule-standalone-2.2.1/lib/boot/mule-module-boot-2.2.1.jar;C:\ESB\mule-standalone-2.2.1/lib/boot/slf4j-api-1.5.0.jar;C:\ESB\mule-standalone-2.2.1/lib/boot/slf4j-log4j12-1.5.0.jar;C:\ESB\mule-standalone-2.2.1/lib/boot/wrapper-3.2.3.jar
      Library path: 
      %LD_LIBRARY_PATH%;C:\ESB\mule-standalone-2.2.1/lib/boot
      Boot class path: 
      C:\Program Files\Java\jdk1.6.0_13\jre\lib\resources.jar;C:\Program Files\Java\jdk1.6.0_13\jre\lib\rt.jar;C:\Program Files\Java\jdk1.6.0_13\jre\lib\sunrsasign.jar;C:\Program Files\Java\jdk1.6.0_13\jre\lib\jsse.jar;C:\Program Files\Java\jdk1.6.0_13\jre\lib\jce.jar;C:\Program Files\Java\jdk1.6.0_13\jre\lib\charsets.jar;C:\Program Files\Java\jdk1.6.0_13\jre\classes
      i configured tomcat with Xmx256m but i get 520m(the Xmx of mule)
      can any one explain me this ambiguity?