As for that, in this situation I'd probably make the Image Object that contains the image a field of the class and use it to test with. Of course, that's what I'd do - that doesn't mean it's the best solution, since I'm still a nubcake.
pretty code looks good... mmm.. this is purty..
ok now I'm just getting incompatible types for the line:I'm pretty sure get/setIcon() work with Icon, not ImageIcon. But you can easily look that up.
ImageIcon temp = btnBotC8.getIcon();
---------HERE?Yes. The only reason for calling it blankIcon rather than pic9 is that the first name stands more chance of being recognisable for what it is elsewhere in the code.