This discussion is archived
7 Replies Latest reply: Jan 17, 2013 10:00 PM by user7490278 RSS

Oracle11g on Solaris 10

800865 Newbie
Currently Being Moderated
Hi,

I'm trying to install Oracle11g on a Solaris 10 machine.

The pre-install script reports that I have an old kernel, and fails.

INFO: OS Kernel Version: This is a prerequisite condition to test whether the system kernel version is at least "5.10-2008.10".
INFO: Severity:CRITICAL
INFO: OverallStatus:VERIFICATION_FAILED
INFO: Verification Result for Node:negro
INFO: Expected Value:5.10-2008.10
INFO: Actual Value:5.10-2005.01.22.19.14
INFO: Error Message:Kernel of proper version is not found on node "negro" [Expected = "5.10-2008.10" ; Found =
"5.10-2005.01.22.19.14"]

The base installation of the server was Solaris 10 3/05 with Oracle10g. But it was patched several times during it's lifetime with Sunsolve recomended patches, and I'm runing a newer kernel than 5.10-2008-10.

# uname -a
SunOS negro 5.10 Generic_*142900-08* sun4u sparc SUNW,Sun-Fire-V440

#cat /var/sadm/patch/142900-08/README.142900-08
Synopsis: SunOS 5.10: kernel patch
Date: Apr/08/2010

# pkginfo -l SUNWcsr
PKGINST: SUNWcsr
NAME: Core Solaris, (Root)
CATEGORY: system
ARCH: sparc
VERSION: 11.10.0,REV=2005.01.21.15.53
BASEDIR: /
VENDOR: Sun Microsystems, Inc.
DESC: core software for a specific instruction-set architecture
PSTAMP: on10ptchfeat20080519070325
INSTDATE: Apr 18 2010 00:22
HOTLINE: Please contact your local service provider
STATUS: completely installed
FILES: 503 installed pathnames
50 shared pathnames
10 linked files
118 directories
97 executables
6650 blocks used (approx)

Can I ignore the pre-install check?

Because as I understand the other way is to update with "Solaris Update Patch Bundles" to Solaris 10 9/10 SPARC Bundle which will change the package versions and Oracle will not object?

Thank you.
  • 1. Re: Oracle11g on Solaris 10
    591186 Guru
    Currently Being Moderated
    Post the results of:

    cat /etc/release

    -Anantha
  • 2. Re: Oracle11g on Solaris 10
    askraks Pro
    Currently Being Moderated
    Hi,


    I think you need upgrade the kernel

    "5.10-2008.10" from 5.10-2005.01.22.19.14"

    Ignore, i doubt you get error during the installation

    Kind Regards,
    Rakesh Jayappa
  • 3. Re: Oracle11g on Solaris 10
    Mohamed ELAzab Pro
    Currently Being Moderated
    I recommend that you do all the updates before going further if you ignored that it may work right now but after that while you are in production you may get many errors and find yourself in a trouble so do it right.upgrade the kernal and then install oracle.
    Kind regards
    Mohamed
  • 4. Re: Oracle11g on Solaris 10
    800865 Newbie
    Currently Being Moderated
    The /etc/release is old - from the initial install of the system.
    # cat /etc/release
    Solaris 10 3/05 s10_74L2a SPARC
    Copyright 2005 Sun Microsystems, Inc. All Rights Reserved.
    Use is subject to license terms.
    Assembled 22 January 2005

    The running kernel is couple of months old.
    # uname -a
    SunOS negro 5.10 Generic_*142900-08* sun4u sparc SUNW,Sun-Fire-V440


    I have another server installed from Solaris 10/09 DVD and it has the same kernel, since I patched it with the same Recommended cluster patch from Solaris but a newer /etc/release.

    #uname -a
    SunOS mirko 5.10 Generic_*142900-08* sun4u sparc SUNW,Sun-Fire-880

    #cat /etc/release
    Solaris 10 10/09 s10s_u8wos_08a SPARC
    Copyright 2009 Sun Microsystems, Inc. All Rights Reserved.
    Use is subject to license terms.
    Assembled 16 September 2009
  • 5. Re: Oracle11g on Solaris 10
    820071 Newbie
    Currently Being Moderated
    Hi There,

    I faced the same issue while installing Oracle 11g on Solaris. Rather taking from /etc/release. Oracle checks the version of Kernal from 'pkginfo -l SUNWsolnm'
    Update the latest patchset on the server and uninstall SUNWsolnm and install the same package from Solaris10 9/10 or any updated version avilable with you.
    Installation should work successfully,

    Cheers,
    Chandra
  • 6. Re: Oracle11g on Solaris 10
    ora_et_labora Newbie
    Currently Being Moderated
    Hi there,
    I found this thread while troubleshooting a similar issue and I'd like to clarify one thing:

    Oracle requires your Solaris to be completely upgraded to 5.10 Update 6 or later. Single patches and maintenance updates won't do the trick! Thus, even if your kernel version is higher than what the installer requires, still some important packages might be missing. I think OUI and the Installation Guide aren't clear about this, but [Doc ID 971464.1|https://supporthtml.oracle.com/ep/faces/secure/km/DocumentDisplay.jspx?id=971464.1] is. Quote:
    7. Is applying a kernel patch or a Solaris patch bundle the equivalent to installing the specific Solaris 10 "update 6" image?
    No, it is not. The OS kernel can be updated to U6 levels (or later) with MU (Maintenance Update) patch bundles, or with the individual kernel patch. However, according to Oracle's Solaris team, this is not the same as the update level that Oracle Development built and certified 11gR2 with.
    This means that you have to update your OS using a complete release >= 5.10 u6.


    Kind regards,
    Uwe
  • 7. Re: Oracle11g on Solaris 10
    user7490278 Newbie
    Currently Being Moderated
    wow solnm worked for us...

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points