This discussion is archived
3 Replies Latest reply: Sep 28, 2010 2:28 AM by user133578 RSS

Issue in enabling Oracle Enterprise Manager in R12

user133578 Newbie
Currently Being Moderated
****************************************
I tried to enable OEM in my R12 Instance

****************************************
$ emca -config dbcontrol db -repos create

STARTED EMCA at Sep 28, 2010 11:58:17 AM
EM Configuration Assistant, Version 10.2.0.1.0 Production
Copyright (c) 2003, 2005, Oracle. All rights reserved.

Enter the following information:
Database SID: TEST
Listener port number: 1521
Password for SYS user:
Password for DBSNMP user:
Password for SYSMAN user:
Password for SYSMAN user: Email address for notifications (optional):
Outgoing Mail (SMTP) server for notifications (optional):
-----------------------------------------------------------------

You have specified the following settings

Database ORACLE_HOME ................ /prodapps/oratest/TEST/db/tech_st/10.2.0

Database hostname ................ hostname.domainname
Listener port number ................ 1521
Database SID ................ TEST
Email address for notifications ...............
Outgoing Mail (SMTP) server for notifications ...............

-----------------------------------------------------------------
Do you wish to continue? [yes(Y)/no(N)]: Y
Sep 28, 2010 11:58:37 AM oracle.sysman.emcp.EMConfig perform
INFO: This operation is being logged at /prodapps/oratest/TEST/db/tech_st/10.2.0/cfgtoollogs/emca/TEST/emca_2010-09-28_11-58-17-AM.log.
Sep 28, 2010 11:58:38 AM oracle.sysman.emcp.EMReposConfig createRepository
INFO: Creating the EM repository (this may take a while) ...
Sep 28, 2010 12:02:02 PM oracle.sysman.emcp.EMReposConfig invoke
INFO: Repository successfully created
Sep 28, 2010 12:02:07 PM oracle.sysman.emcp.util.DBControlUtil startOMS
INFO: Starting Database Control (this may take a while) ...
Sep 28, 2010 12:02:18 PM oracle.sysman.emcp.EMDBPostConfig performConfiguration
INFO: Database Control started successfully
Sep 28, 2010 12:02:18 PM oracle.sysman.emcp.EMDBPostConfig performConfiguration
INFO: >>>>>>>>>>> The Database Control URL is http://hostname.domain:1158/em <<<<<<<<<<<
Enterprise Manager configuration completed successfully
FINISHED EMCA at Sep 28, 2010 12:02:18 PM

**************
Checked Status
**************

$ emctl status dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.2.0.2.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://hostname.domain:1158/em/console/aboutApplication
EM Daemon is not running.
------------------------------------------------------------------
Logs are generated in directory /prodapps/oratest/TEST/db/tech_st/10.2.0/hostname.domain_TEST/sysman/log

*******************
Started The service
*******************

$ emctl start dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.2.0.2.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://hostname.domain:1158/em/console/aboutApplication
Starting Oracle Enterprise Manager 10g Database Control .... started.
------------------------------------------------------------------
Logs are generated in directory /prodapps/oratest/TEST/db/tech_st/10.2.0/hostname.domain_TEST/sysman/log

**********************************
Still the status shows not running
**********************************

$ emctl status dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.2.0.2.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://hostname.domain:1158/em/console/aboutApplication
EM Daemon is not running.
------------------------------------------------------------------
Logs are generated in directory /prodapps/oratest/TEST/db/tech_st/10.2.0/hostname.domain_TEST/sysman/log
$


*************************************************************************************
When tried to login with URL ignoring the "not running message"(when checked status):
http://hostname.domain:1158/em
*************************************************************************************

Got the following error message:

500 Internal Server Error
java.lang.NullPointerException     at oracle.cabo.servlet.xml.UIXPageBroker.getConfigurationName(Unknown Source)     at oracle.cabo.servlet.ui.BaseUIPageBroker.getConfiguration(Unknown Source)     at oracle.cabo.servlet.ui.BaseUIPageBroker.getService(Unknown Source)     at oracle.cabo.servlet.xml.UIXPageBroker.getService(Unknown Source)     at oracle.sysman.emSDK.svlt.EMServlet.initialize(EMServlet.java:417)     at oracle.sysman.eml.app.Console.init(Console.java:360)     at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.1.0)].server.http.HttpApplication.loadServlet(HttpApplication.java:2130)     at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.1.0)].server.http.HttpApplication.findServlet(HttpApplication.java:4560)     at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.1.0)].server.http.HttpApplication.getRequestDispatcher(HttpApplication.java:2598)     at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.1.0)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:643)     at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.1.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:270)     at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.1.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:112)     at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.1.0)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:186)     at java.lang.Thread.run(Thread.java:568)

Edited by: M.U.N.A on Sep 28, 2010 12:49 PM
  • 1. Re: Issue in enabling Oracle Enterprise Manager in R12
    Helios-GunesEROL Oracle ACE
    Currently Being Moderated
    Hi MUNA;

    Please check below thread

    configuring OEM for 10g on R12
    Re: configuring OEM for 10g on R12 Apps Server *<< posted by Hussein Sawwan*

    Regard
    Helios
  • 2. Re: Issue in enabling Oracle Enterprise Manager in R12
    user133578 Newbie
    Currently Being Moderated
    Unknowingly followed the same steps. But getting the error.

    Following are the error messages: I saw in $ORACLE_HOME/host.domain_SID/sysman/log/emdb.nohup

    10/09/28 13:08:16 Auto-deploying file:/prodapps/oratest/TEST/db/tech_st/10.2.0/o
    c4j/j2ee/oc4j_applications/applications/em/em/ (New server version detected)...
    10/09/28 13:08:20 log4j:ERROR No appenders could be found for category (emSDK.co
    nf).
    10/09/28 13:08:20 log4j:ERROR Please initialize the log4j system properly.
    10/09/28 13:08:21 java.lang.NoClassDefFoundError: oracle/cabo/ui/UIExtension
    10/09/28 13:08:21 ...
    ...

    Following are the error messages: I saw in $ORACLE_HOME/host.domain_SID/sysman/log/emoms.log &
    $ORACLE_HOME/host.domain_SID/sysman/log/emoms.trc

    2010-09-28 13:30:25,408 [Orion Launcher] ERROR app.ContextInitializer contextIni
    tialized.271 - Integration Class not found: oracle.sysman.ias.ias.IASIntegration
    2010-09-28 13:30:25,912 [Orion Launcher] ERROR app.ContextInitializer contextIni
    tialized.271 - Integration Class not found: oracle.sysman.eml.target.slb.common.
    SLBIntegration
    2010-09-28 13:30:26,056...
    ...

    Please help.
  • 3. Re: Issue in enabling Oracle Enterprise Manager in R12
    Helios-GunesEROL Oracle ACE
    Currently Being Moderated
    Hi;

    Source your env file;

    What is emctl status dbconsole return?

    If it is running, try restarting the dbconsole with
    emctl stop dbconsole
    emctl start dbconsole

    Regard
    Helios

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points