1 2 Previous Next 18 Replies Latest reply: Mar 31, 2009 5:09 AM by 800305 RSS

    Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse

    843785
      I got the following exception in JBOSS 5.0.0 GA in eclipse 3.4 Ganymede.I have listed the exceptions below.Server status is set as "started" but i got error while running the server in browser.

      java.lang.ClassNotFoundException: javax.jnlp.UnavailableServiceException
      javax.naming.CommunicationException
      java.net.SocketTimeoutException
      javax.naming.ServiceUnavailableException
      java.net.ConnectException
        • 1. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
          800305
          Repost your question on eclipse forum or JBoss.org. forum.
          I know, they help You.


          hmm...
          what page You want open in web browser?
          developed for You or default server start page ?

          Edited by: Skowroniasty on Mar 19, 2009 1:46 PM
          • 2. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
            843785
            i am deploying my adempiere source code .so in start up page adempiere first page should come.pls help some other way
            • 3. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
              800305
              ...
              You see this exception only if you open Your web app ?
              and when you open default jboos start page it is all OK?
              if yes:
              1.
              Check info about Your exception,
              http://java.sun.com/j2se/1.4.2/docs/api/java/lang/Exception.html
              2. can you paste your code?

              Edited by: Skowroniasty on Mar 19, 2009 2:16 PM
              • 4. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                r035198x
                Skowroniasty wrote:
                ...
                You see this exception only if you open Your web app ?
                and when you open default jboos start page it is all OK?
                if yes:
                1.
                Check info about Your exception,
                http://java.sun.com/j2se/1.4.2/docs/api/java/lang/Exception.html
                2. can you paste your code?

                Edited by: Skowroniasty on Mar 19, 2009 2:16 PM
                That's a rather old link these days.


                @OP : I would suggest posting this in the adempiere forums where you might be told to ensure that you have successfully run both the build.xml in the utils_dev folder and the RUN_setup.sh/bat in the Adempiere folder.
                • 5. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                  843785
                  *** 2009-03-19 18:53:15.421 Adempiere Log (CLogConsole) ***
                  18:53:15.421 Adempiere.startup: Adempiere(r) Release 3.5.3a_2008-12-21 -Smart Suite ERP,CRM and SCM- (c) 1999-2009 Adempiere (r); Implementation: ADempiere - Supported by ADempiere community
                  18:53:16.421 Ini.loadProperties: C:\Documents and Settings\Intern\Adempiere.properties #38
                  [INFO] MLog clients using com.mchange.v2.log.FallbackMLog logging.
                  [INFO] Initializing c3p0-0.9.1.2 [built 21-May-2007 15:04:56; debug? true; trace: 10]
                  -----------> CConnection.isAppsServerOK: jnp://ace-3:1099
                  - javax.naming.CommunicationException: Could not obtain connection to any of these urls: ace-3:1099 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] [Root exception is javax.naming.CommunicationException: Failed to connect to server ace-3:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server ace-3:1099 [Root exception is java.net.ConnectException: Connection refused: connect]]]
                  - {java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory, java.naming.provider.url=jnp://ace-3:1099, jnp.discoveryTimeout=5000, jnp.timeout=5000, java.naming.factory.url.pkgs=org.jboss.naming.client, jnp.sotimeout=5000}
                  javax.naming.CommunicationException: Could not obtain connection to any of these urls: ace-3:1099 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] [Root exception is javax.naming.CommunicationException: Failed to connect to server ace-3:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server ace-3:1099 [Root exception is java.net.ConnectException: Connection refused: connect]]]
                       at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1562)
                       at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:634)

                       at java.lang.Class.newInstance(Unknown Source)
                       at org.compiere.Adempiere.main(Adempiere.java:582)
                  Caused by: javax.naming.CommunicationException: Failed to connect to server ace-3:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server ace-3:1099 [Root exception is java.net.ConnectException: Connection refused: connect]]
                       at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:274)
                       at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1533)
                       ... 17 more
                  Caused by: javax.naming.ServiceUnavailableException: Failed to connect to server ace-3:1099 [Root exception is java.net.ConnectException: Connection refused: connect]
                       at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:248)
                       ... 18 more
                  Caused by: java.net.ConnectException: Connection refused: connect
                       at java.net.PlainSocketImpl.socketConnect(Native Method)
                       at java.net.PlainSocketImpl.doConnect(Unknown Source)
                       at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
                       at java.net.PlainSocketImpl.connect(Unknown Source)
                       at java.net.SocksSocketImpl.connect(Unknown Source)
                       at java.net.Socket.connect(Unknown Source)
                       at java.net.Socket.connect(Unknown Source)
                       at java.net.Socket.<init>(Unknown Source)
                       at java.net.Socket.<init>(Unknown Source)
                       at org.jnp.interfaces.TimedSocketFactory$ConnectThread.run(TimedSocketFactory.java:163)
                  [INFO] Initializing c3p0 pool... com.mchange.v2.c3p0.ComboPooledDataSource [ acquireIncrement -> 3, acquireRetryAttempts -> 2, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, dataSourceName -> AdempiereDS, debugUnreturnedConnectionStackTraces -> false, description -> null, driverClass -> oracle.jdbc.OracleDriver, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -> 1hge13b808kngbm1ulo5ib|12d7a10, idleConnectionTestPeriod -> 1200, initialPoolSize -> 1, jdbcUrl -> jdbc:oracle:thin:@//ace-3:1521/xe, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 900, maxIdleTimeExcessConnections -> 1200, maxPoolSize -> 15, maxStatements -> 0, maxStatementsPerConnection -> 0, minPoolSize -> 1, numHelperThreads -> 3, numThreadsAwaitingCheckoutDefaultUser -> 0, preferredTestQuery -> SELECT Version FROM AD_System, properties -> {user=******, password=******}, propertyCycle -> 0, testConnectionOnCheckin -> false, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, usesTraditionalReflectiveProxies -> false ]

                  *** 2009-03-19 18:53:53.828 Adempiere Log (CLogConsole) ***
                  • 6. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                    r035198x
                    Do you have an entry in the host file for the ace-3 machine?
                    What happens if you use the IP address of the server machine rather than the name?

                    P.S I still think this belongs in the adempiere forums.
                    • 7. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                      800305
                      check error list:
                      http://www.adempiere.com/wiki/index.php/InstallServer

                      check your config ports and windows firewall or your personal firewall soft.

                      Edited by: Skowroniasty on Mar 19, 2009 2:38 PM
                      • 8. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                        843785
                        i change ip address as 127.0.0.1 but still i got same problem..
                        • 9. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                          843785
                          i think the information you gave was applicable for binary version of adempiere.Now I am working with the source code version of adempiere in eclipse....Can you suggest what should i do for that?
                          • 10. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                            r035198x
                            Did you run the RUN_Server2.sh script?
                            • 11. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                              r035198x
                              sathishbliss wrote:
                              i think the information you gave was applicable for binary version of adempiere.Now I am working with the source code version of adempiere in eclipse....Can you suggest what should i do for that?
                              No it was for the source code. The build.xml compiles all the source code, the Adempiere/RUN_setup.sh sets up the jboss folders and the Adempiere/utils/RUN_Server2.sh starts the server (jboss). All this should be documented somewhere on the Adempiere sites.
                              • 12. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                                843785
                                Actually I am working in windows OS.I started the Run_server2.bat file while was working with binary version of adempiere.Now I need solution for binary version of adempiere.
                                • 13. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                                  r035198x
                                  You still need to compile the sources (build.xml in the utils_dev folder), then run the RUN_setup.bat in the generated Adempiere folder, if it is successful you can then start the server with Adempiere/utils/RUN_Server.sh.
                                  P.S This is my last post in this thread because I really think this discussion is happening out of place.
                                  • 14. Re: Help in  solving Exception while starting JBOSS 5.0.0GA in eclipse
                                    800305
                                    i think the information you gave was applicable for binary version of adempiere.Now I am working with the source >>>code version of adempiere in eclipse....Can you suggest what should i do for that?
                                    OK.
                                    Can You compile from source without errors ?
                                    If yes, you should check the error list, or download the binary and install them,if after this step all is OK, we should search error in other place

                                    Edited by: Skowroniasty on Mar 19, 2009 2:58 PM
                                    1 2 Previous Next