This content has been marked as final. Show 3 replies
validateOrChange() or validateOrChangeParams()
I really think it's overkill to have the name indicate any more detail than that. Method names should be self-documenting--to a point. A competent programmer would make the educated guess that they'll only be changed if they're invalid, and will read the details in the javadocs.