1 Reply Latest reply: Oct 24, 2008 9:42 AM by 843802 RSS

    Speech recognition with voce as applet

    843802
      Hi,
      did someone ever experienced to implement a speech recognition with the voce project (http://voce.sourceforge.net)?

      i built one was able to run it as an applikation, but i need the speech rec. as an applet.
      I tried to build an applet and it worked well when i invoke it in eclipse. When i want to launch
      it in my browser, i run into this errors:
      Java-Konsole: init... !
      init Applet
      [Voce] Initializing recognizer. This may take some time...
      java.security.AccessControlException: access denied (java.util.PropertyPermission user.dir read)
      at java.security.AccessControlContext.checkPermission(Unknown Source)
      at java.security.AccessController.checkPermission(Unknown Source)
      at java.lang.SecurityManager.checkPermission(Unknown Source)
      at java.lang.SecurityManager.checkPropertyAccess(Unknown Source)
      at java.lang.System.getProperty(Unknown Source)
      at java.io.Win32FileSystem.getUserPath(Unknown Source)
      at java.io.Win32FileSystem.resolve(Unknown Source)
      at java.io.File.getAbsolutePath(Unknown Source)
      at java.io.File.getAbsoluteFile(Unknown Source)
      at java.io.File.toURI(Unknown Source)
      at voce.SpeechRecognizer.<init>(SpeechRecognizer.java:72)
      at voce.SpeechInterface.init(SpeechInterface.java:79)
      at RecognitionTest.init(RecognitionTest.java:53)
      at sun.applet.AppletPanel.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      i figured out one problem: that was the heap size and this issue can be fixed in the v6 plugin (only
      for windows)...
      do someone face similar probs?

      thanks for your replies
        • 1. Re: Speech recognition with voce as applet
          843802
          hi again,

          i made a little progress an packed the whole applet as jar and when i invoke it in the browser
          the only error message is
          Java-Konsole: init... ! 
          init Applet 
          [Voce] Initializing recognizer. This may take some time... 
          java.lang.NoClassDefFoundError: edu/cmu/sphinx/util/props/PropertyException 
          at voce.SpeechInterface.init(SpeechInterface.java:79) 
          at recognitionTest.init(recognitionTest.java:27) 
          at sun.applet.AppletPanel.run(AppletPanel.java:380) 
          at java.lang.Thread.run(Thread.java:613) 
          i figured out that the problem is policy/security restricitions and tried to
          sign the applet with a selfcert... but run into errors :-)

          is somebody experienced in policy/security things with applets?

          thanks