2 Replies Latest reply on Jul 11, 2009 9:46 AM by 843810

    "javax.help doesn't exist"-error

      Hello there,
      I'm running java on a mac(so I'm using the mac preinstalled java + sdk) and have downloadet javahelp, unpacked it to "/Library/java/home/jh2.0/javahelp" and added ":/Library/Java/Home/jh2.0/javahelp/lib/jh.jar" to CLASSPATH. Also, I have set the JHHOME-Variable to "/Library/Java/Home/jh2.0/javahelp".
      Now, as soon as I try "import javax.help.whatever", it says: "package javax.help doesn't exist".
      I already searched for older threads handling the same error, but they all seemed to have "Write it into CLASSPATH" as the ultimate solution.
      Does anyone have an Idea, why this doesn't seem to work on my machine and how to fix this?
      Thank's in anticipation,

        • 1. Re: "javax.help doesn't exist"-error
          As far as developing I'd add jhall.jar.
          Coming to your problem all I can see is
          N3buk4dn3zz4r wrote:
          unpacked it to "/Library/java/home/jh2.0/javahelp" and added ":/Library/Java/Home/jh2.0/javahelp/lib/jh.jar" to CLASSPATH.
          Library/*java/home*/ became Library/*Java/Home*.
          Being a unix based OS, could it be case-sensitive or it's just mistyping?
          • 2. Re: "javax.help doesn't exist"-error
            The jhall.jar did the job, now it works. Thank you very much.
            The case-sensitivity though is not the problem. Although mac is a unix-based system, it's file system handling isn't case-sensitive, it will find the path, no matter if its capitaled or not.
            But the problem's solved.

            Thank you again,